Last Comment Bug 767389 - about:home and about:newtab are intermittently shown in the Debugger dropdown
: about:home and about:newtab are intermittently shown in the Debugger dropdown
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Developer Tools: Debugger (show other bugs)
: 15 Branch
: All All
: P2 normal (vote)
: Firefox 16
Assigned To: Victor Porof [:vporof][:vp]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-22 08:05 PDT by Ioana (away)
Modified: 2012-07-16 05:26 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
v1 (834 bytes, patch)
2012-07-03 05:48 PDT, Victor Porof [:vporof][:vp]
past: review-
Details | Diff | Review
v1 (882 bytes, patch)
2012-07-14 23:51 PDT, Victor Porof [:vporof][:vp]
past: review+
Details | Diff | Review

Description Ioana (away) 2012-06-22 08:05:06 PDT
Mozilla/5.0 (Windows NT 6.1; rv:15.0) Gecko/20120621 Firefox/15.0a2 (20120621042006)

STR:
1. Launch Firefox with a fresh profile.
2. Open the Debugger (Tools->Web developer->Debugger, or press Ctrl+Shift+S) on about:home or about:newtab.

about:home and about:newtab are sometimes shown in the Debugger dropdown. I have only seen about:newtab once or twice in the dropdown until now, but about:home is displayed somewhat more often.
Comment 1 Victor Porof [:vporof][:vp] 2012-06-28 09:28:24 PDT
This is to be expected, but a fix is quite necessary nonetheless.
Comment 2 Victor Porof [:vporof][:vp] 2012-07-03 05:48:57 PDT
Created attachment 638669 [details] [diff] [review]
v1
Comment 3 Panos Astithas [:past] 2012-07-04 07:45:43 PDT
Comment on attachment 638669 [details] [diff] [review]
v1

Review of attachment 638669 [details] [diff] [review]:
-----------------------------------------------------------------

That's the wrong place to check for the protocol, because it leaves an about:home script in the script list and a dangling "Loading..." message in the editor. See TA__addScript (script actors) for the existing chrome protocol check.
Comment 4 Victor Porof [:vporof][:vp] 2012-07-14 23:51:23 PDT
Created attachment 642341 [details] [diff] [review]
v1
Comment 5 Panos Astithas [:past] 2012-07-15 06:43:23 PDT
https://hg.mozilla.org/integration/fx-team/rev/206b75c9d58e
Comment 6 Ed Morley [:emorley] 2012-07-16 05:26:43 PDT
https://hg.mozilla.org/mozilla-central/rev/206b75c9d58e

Note You need to log in before you can comment on or make changes to this bug.