unified search results aren't filtering out documents by model correctly

RESOLVED FIXED in 2012.12

Status

P1
normal
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: willkg, Assigned: willkg)

Tracking

unspecified
2012.12

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: u=user c=search p=1)

If you do an Advanced Search just for questions, you get results for kb articles, questions and forums. That's wrong--it should only return results for questions.

I'm pretty sure the problem is the filter code I just fixed. I need to tweak the model filtering a bit.


Putting this in the 2012.12 sprint as a 1 pointer. I'm 99% sure my theory is right and if so, it's really easy to fix. Plus I'll write up some tests to verify correctness.
Duplicate of this bug: 767458
Duplicate of this bug: 767540
Pushed to production just now.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.