Beginning on October 25th, 2016, Persona will no longer be an option for authentication on BMO. For more details see Persona Deprecated.
Last Comment Bug 767399 - When navigating between web pages with the Back and Forward buttons, the same scripts are displayed in the Debugger for all the pages
: When navigating between web pages with the Back and Forward buttons, the same...
Product: Firefox
Classification: Client Software
Component: Developer Tools: Debugger (show other bugs)
: 15 Branch
: All All
: P2 normal (vote)
: Firefox 16
Assigned To: Panos Astithas [:past]
: James Long (:jlongster)
Depends on: 774619
  Show dependency treegraph
Reported: 2012-06-22 08:31 PDT by Ioana (away)
Modified: 2012-08-03 07:09 PDT (History)
4 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---

Working patch (6.56 KB, patch)
2012-07-06 10:00 PDT, Panos Astithas [:past]
rcampbell: review+
akeybl: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Ioana (away) 2012-06-22 08:31:30 PDT
Mozilla/5.0 (Windows NT 6.1; rv:15.0) Gecko/20120621 Firefox/15.0a2 (20120621042006)

1. Load any web page with JSs in the browser.
2. Open the Debugger (Tools->Web developer->Debugger, or press Ctrl+Shift+S).
3. Load another web page in the same tab. Notice that the scripts dropdown gets updated accordingly.
4. Click on the Back button.

The scripts dropdown doesn't get updated at step 4. When navigating between web pages with the Back and Forward buttons, the scripts from the page loaded last in the browser are displayed in the Debugger for all the pages.
Comment 1 Victor Porof [:vporof][:vp] 2012-06-22 09:51:04 PDT
Hmm, I can trigger this if I additionally click the Forward button after step 4.

Tested with

Comment 2 Panos Astithas [:past] 2012-06-25 04:28:14 PDT
In Nightly I see the behavior Victor describes in comment 1. I haven't tested with Aurora to see if I can reproduce Ioana's symptoms. The problem is that forward (and maybe back) doesn't seem to trigger a DOMWindowCreated event, which hoses our navigation logic.
Comment 3 Panos Astithas [:past] 2012-07-06 10:00:02 PDT
Created attachment 639709 [details] [diff] [review]
Working patch

Adding a pageshow handler fixes this.
Comment 4 Panos Astithas [:past] 2012-07-06 10:00:28 PDT
Try run:
Comment 5 Rob Campbell [:rc] (:robcee) 2012-07-10 12:51:47 PDT
Comment on attachment 639709 [details] [diff] [review]
Working patch

looks good.
Comment 6 Panos Astithas [:past] 2012-07-12 04:06:50 PDT
Comment 7 Tim Taubert [:ttaubert] 2012-07-13 03:10:12 PDT
Comment 8 Panos Astithas [:past] 2012-07-13 04:11:59 PDT
Comment on attachment 639709 [details] [diff] [review]
Working patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): New feature
User impact if declined: developers would have to reload the page after going back or forward in history, in order for the debugger to display the actual page contents
Testing completed (on m-c, etc.): On m-c and fx-team
Risk to taking this patch (and alternatives if risky): pretty trivial patch, minor risk
String or UUID changes made by this patch: none
Comment 9 Alex Keybl [:akeybl] 2012-07-13 13:53:04 PDT
Comment on attachment 639709 [details] [diff] [review]
Working patch

[Triage Comment]
New feature, developer focused release, and low risk. Approved for Aurora 15. Please land ASAP to make it in before Monday's merge.
Comment 11 Ioana (away) 2012-08-03 07:09:14 PDT
Verified as fixed on:
Mozilla/5.0 (X11; Linux i686; rv:15.0) Gecko/20100101 Firefox/15.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:15.0) Gecko/20100101 Firefox/15.0
Mozilla/5.0 (Windows NT 6.1; rv:15.0) Gecko/20100101 Firefox/15.0

Note You need to log in before you can comment on or make changes to this bug.