mozilla\xpfe\components\build\nsModule.cpp contains compile time errors

VERIFIED WORKSFORME

Status

SeaMonkey
UI Design
VERIFIED WORKSFORME
17 years ago
14 years ago

People

(Reporter: MatthiasMann, Assigned: dougt)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
When I build mozilla I got the following error:

mozilla\xpfe\components\build\nsModule.cpp(107) : error C2440: 'initializing' :
'' kann nicht in 'unsigned int (__stdcall *)(class nsIComponentManager *,class
nsIFile *,const char *,const char *,const struct nsModuleComponentInfo *)'
konvertiert werden

or translated into english:
mozilla\xpfe\components\build\nsModule.cpp(107) : error C2440: 'initializing' :
'' can't convert to 'unsigned int (__stdcall *)(class nsIComponentManager
*,class nsIFile *,const char *,const char *,const struct nsModuleComponentInfo *)'

Comment 1

17 years ago
-> xpapps
Assignee: waterson → pchen
Component: XP Miscellany → XP Apps
QA Contact: brendan → sairuh

Comment 2

17 years ago
73 NS_DOCUMENT_LOADER_FACTORY_CONTRACTID_PREFIX
"view;1?type=application/http-index-format",

http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/xpfe/components/build/nsMod
ule.cpp&rev=1.10&mark=107#100

=>dougt, per blame :(

http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/xpfe/components/build/nsMod
ule.cpp&mark=58-62,79-83#55

'' can't convert to 'unsigned int (__stdcall *)(class nsIComponentManager
*,class nsIFile *,const char *,const char *,const struct nsModuleComponentInfo 
*)'
This describes RegisterProc

http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/xpcom/components/nsIGeneric
Factory.h&rev=1.22&mark=68-72,74-77#65

Since the tinders didn't complain, ... reporter: i suspect we need more info, 
what compiler are you using?
Assignee: pchen → dougt

Comment 3

17 years ago
...more questions, reporter: you shouldn't mark a compile error OS:All, please 
tell us which os you were using [linux?] and update the field.
(Assignee)

Comment 4

17 years ago
works for me on windows/mac/linux.  THe ports aren't dying. 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 5

17 years ago
The problem was solved by pulling a new tree 8 hours later. It seems like I've
pulled this file at the wrong moment.

But it would be nice to write a better compilation guide for mozilla. I'm still
unamble to build mozilla.

Should I write a loop like this to pull and build mozilla ?
  :start
  nmake /f client.mak clobber
  if errorlevel 1 goto start
  nmake /f client.mak pull_all
  if errorlevel 1 goto start
  nmake /f client.mak build_all
  if errorlevel 1 goto start
(Assignee)

Comment 6

17 years ago
better complication guide?  like any other concurrent development project, the 
tip is a risky place to be.  
mass verification of WorksForMe bugs: to find all bugspam pertaining to this,
set your search string to "IfItWorksForSlappyTheSquirrelThenItWFM".

if you think this particular bug is *still* an open issue, please make sure of
the following before reopening:

a. that it's still a problem with ***recent trunk builds*** on the all
appropriate platform[s]

b. provide clear steps to reproduce (unless a good test case is already in the
bug report), making sure it pertains to the original problem (avoid morphing as
much as possible :)
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.