App lookup Search doesn't find expected results

RESOLVED FIXED in 2012-07-05

Status

Marketplace
Admin Tools
P1
normal
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: krupa, Assigned: robhudson)

Tracking

2012-07-05
Points:
---

Details

(URL)

(Reporter)

Description

6 years ago
steps to reproduce:
1. Load https://marketplace-dev.allizom.org/en-US/account-lookup/
2. In app lookup, search for 'mozilla marketplace'

expected behavior:
Search finds https://marketplace-dev.allizom.org/en-US/account-lookup/app/370006/summary

observed behavior:
no results found.

Searching for "marketplace" finds the app.

Other apps with the same issue-
* Searching for Sandglaz returns no results
* Searching for "Evernote Web" returns no results but searching for "Evernote" finds the app
Any great ideas on this Allen?  I know you're already looking at the case bug for ES
Assignee: nobody → ashort
Blocks: 766201
No longer blocks: 752013
Target Milestone: --- → 2012-07-12
(Assignee)

Comment 2

6 years ago
https://github.com/mozilla/zamboni/commit/8200ecd 

Sorry for stealing this, ashort. I was curious and then figure out what was up, so I fixed it.
Assignee: ashort → robhudson.mozbugs
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: 2012-07-12 → 2012-07-05
(Assignee)

Comment 3

6 years ago
And a bit of a tweak for better boosting of results:
https://github.com/mozilla/zamboni/commit/613b828
(Reporter)

Comment 4

6 years ago
Searching for "Mozilla Market" doesn't find the Marketplace. Let me know if you'd prefer a different bug for this.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
blocking-basecamp: --- → +
Priority: -- → P1
(Assignee)

Comment 5

6 years ago
I played around with this using the exact same querying we're doing on the site search and wondering why the site search finds the marketplace app when searching for "Mozilla Market", yet this app lookup does not.

The reason is that the addons search results overwhelm the results for this query and the marketplace app doesn't score high enough to be included. The output from ES shows that there are 515 results, the lowest score being 7.953125. When I tweak it to filter only by apps, the marketplace app shows up at top with a score of 4.8046512999999997 -- which is apparently below whatever threshold elasticsearch came up with in trying to return relevant results when including addons.

My suggestion: separate apps and add-ons searches. Which means the lookup tool would have 3 boxes: User search, app search, add-on search. We could then use a similar query here that we do for site search for consistency, minus the status=public and/or is_disabled=False filters.
(In reply to Rob Hudson [:robhudson] from comment #5)
> My suggestion: separate apps and add-ons searches. Which means the lookup
> tool would have 3 boxes: User search, app search, add-on search. We could
> then use a similar query here that we do for site search for consistency,
> minus the status=public and/or is_disabled=False filters.

This would be easiest, yeah. I think this makes perfect sense.
wfm
(Assignee)

Comment 8

6 years ago
https://github.com/mozilla/zamboni/commit/f3199fd
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED
Not on-device - removing nom.
blocking-basecamp: + → ---
You need to log in before you can comment on or make changes to this bug.