FireFox does not handle absence of 32-bit plug-in properly

RESOLVED DUPLICATE of bug 823533

Status

()

--
major
RESOLVED DUPLICATE of bug 823533
6 years ago
5 years ago

People

(Reporter: towatson, Unassigned)

Tracking

13 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:12.0) Gecko/20100101 Firefox/12.0
Build ID: 20120420145725

Steps to reproduce:

Built a Mac plug-in that only contains a 64-bit binary (not universal, no 32-bit).  My plug-in is associated with the PDF MIME type.  Then I tried to view a PDF in FireFox running in 32-bit mode.


Actual results:

I got a blank page.


Expected results:

As my plug-in does not support 32-bit, I expected to get the default FireFox behavior in this case which is to prompt the user to open or save a file.  

Note that my plug-in was also shown in the list of plugins with about:plugins.  I am not sure that the right behavior is for this, but I would think that my plug-in would be listed when running in 64-bit mode and not listed when running in 32-bit mode.
(Reporter)

Updated

6 years ago
Severity: normal → major
OS: Windows 7 → Mac OS X
Priority: -- → P4
Does it work if you run Firefox in the 32bit mode ?
Component: Untriaged → Plug-ins
Priority: P4 → --
Product: Firefox → Core
QA Contact: untriaged → plugins
(Reporter)

Comment 2

6 years ago
Our plugin is built only for 64-bit.  If we run FF in 64-bit mode it all works.  But if we run FF in 32 bit mode I would expect the FF default behavior since our plug-in has no 32-bit executable.  However, instead FF displays a blank screen. So the 32-bit case is where the bug occurs.  Sorry if this was not clear.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 823533
You need to log in before you can comment on or make changes to this bug.