Pinned tab may lost after crash

RESOLVED WORKSFORME

Status

()

Firefox
Session Restore
RESOLVED WORKSFORME
6 years ago
2 years ago

People

(Reporter: wimyogya, Unassigned)

Tracking

13 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20100101 Firefox/13.0.1
Build ID: 20120614114901

Steps to reproduce:

Firefox still crashes too often. In those cases often (but not always) the Pinned AppTabs are lost upon recovery of the session. 


Actual results:

They serve as my homepage, but are NOT included in the Options > Homepage box.
Since I have about 20 of them pinned, it is a lot of work to re-enter all the home page websites one by one, pin them again. 



Expected results:

Well, three things:
1. Firefox should not crash (that often)...
2. Upon a crash the Pinned AppTabs should be recovered if I use the session recovery feature
3. The Pinned AppTabs should also be mentioned in the Options > Homepage box, for easy reconstruction in case of unexpected trouble - and to copy/paste a long list of home page tabs into another computer (since sync can not do that)

Updated

2 years ago
Component: Untriaged → Session Restore
Summary: Pin-as-AppTab feature not stable → Pinned tab may lost after crash

Comment 1

2 years ago
User Agent 	Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:46.0) Gecko/20100101 Firefox/46.0
Version 	46.0a1
Build ID 	20160112030207
Channel 	nightly

Thank you for taking time to report this.
Are you still able to reproduce this in the latest version ? Can you give more detail on how to reproduce ?
Flags: needinfo?(wimyogya)
Hi reporter,

I haven't managed to reproduce this issue on the latest release(44.0) nor latest Nightly(47.0a1). The pined websites were in their place.

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:44.0) Gecko/20100101 Firefox/44.0
Build ID: 20160123151951

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:47.0) Gecko/20100101 Firefox/47.0
Build ID: 20160129030206

Can you please try to reproduce this on the latest release(44.0) and latest Nightly(47.0a1) and provide the results? When doing this, please try to reproduce with a new clean Firefox profile, maybe even in safe mode, as some of this issues may be caused by third party installed add-ons or custom settings(https://support.mozilla.org/en-US/kb/troubleshoot-and-diagnose-firefox-problems).

Thanks,
Paul.

Comment 3

2 years ago
Considering the fact that I and Paul (@comment 2)cannot reproduce this and the fact that the reporter did not answer to our requests until now, I will mark this as resolved-worksforme.
If anyone can still reproduce it, feel free to reopen the issue and provide more information.

Thanks
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(wimyogya)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.