Closed Bug 767906 Opened 9 years ago Closed 9 years ago

Intermittent crash during test_Range-surroundContents.html | Exited with code -1073741819 during test run (Missing stack)

Categories

(Core :: DOM: Core & HTML, defect)

x86
Windows 7
defect
Not set
critical

Tracking

()

RESOLVED INVALID

People

(Reporter: emorley, Unassigned)

References

Details

(Keywords: crash, intermittent-failure, Whiteboard: [badslave?][talos-r3-w7-038])

Rev3 WINNT 6.1 mozilla-inbound pgo test mochitests-2/5 on 2012-06-23 02:56:23 PDT for push 31e6d7c6ac5d

slave: talos-r3-w7-038

https://tbpl.mozilla.org/php/getParsedLog.php?id=12928383&tree=Mozilla-Inbound

{
5526 INFO TEST-PASS | /tests/dom/imptests/webapps/DOMCore/tests/approved/test_Range-surroundContents.html | Elided 100 passes or known failures.
5527 INFO TEST-PASS | /tests/dom/imptests/webapps/DOMCore/tests/approved/test_Range-surroundContents.html | 59,7: resulting range position for range [xmlDocfrag, 0, xmlDocfrag, 0], node detachedPara1.firstChild
TEST-UNEXPECTED-FAIL | /tests/dom/imptests/webapps/DOMCore/tests/approved/test_Range-surroundContents.html | Exited with code -1073741819 during test run
INFO | automation.py | Application ran for: 0:04:28.444000
INFO | automation.py | Reading PID log: c:\users\cltbld\appdata\local\temp\tmpx7pttypidlog
Downloading symbols from: http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-inbound-win32-pgo/1340434957/firefox-16.0a1.en-US.win32.crashreporter-symbols.zip
PROCESS-CRASH | /tests/dom/imptests/webapps/DOMCore/tests/approved/test_Range-surroundContents.html | application crashed (minidump found)
Crash dump filename: c:\users\cltbld\appdata\local\temp\tmp4zf1if\minidumps\aeb0947d-dabc-477b-af90-1549f0513295.dmp
stderr from minidump_stackwalk:
2012-06-23 03:03:03: minidump_processor.cc:264: INFO: Processing minidump in file c:\users\cltbld\appdata\local\temp\tmp4zf1if\minidumps\aeb0947d-dabc-477b-af90-1549f0513295.dmp
cygwin warning:
  MS-DOS style path detected: c:\users\cltbld\appdata\local\temp\tmp4zf1if\minidumps\aeb0947d-dabc-477b-af90-1549f0513295.dmp
  Preferred POSIX equivalent is: /cygdrive/c/users/cltbld/appdata/local/temp/tmp4zf1if/minidumps/aeb0947d-dabc-477b-af90-1549f0513295.dmp
  CYGWIN environment variable option "nodosfilewarning" turns off this warning.
  Consult the user's guide for more details about POSIX paths:
    http://cygwin.com/cygwin-ug-net/using.html#using-pathnames
2012-06-23 03:03:03: minidump.cc:3500: INFO: Minidump opened minidump c:\users\cltbld\appdata\local\temp\tmp4zf1if\minidumps\aeb0947d-dabc-477b-af90-1549f0513295.dmp
2012-06-23 03:03:03: minidump.cc:3545: INFO: Minidump not byte-swapping minidump
2012-06-23 03:03:03: minidump.cc:3383: INFO: MinidumpBreakpadInfo has no dump thread
2012-06-23 03:03:03: minidump.cc:3406: INFO: MinidumpBreakpadInfo has no requesting thread
2012-06-23 03:03:03: minidump.cc:3902: INFO: GetStream: type 1197932546 not present
2012-06-23 03:03:03: minidump.cc:1945: INFO: MinidumpModule could not determine version for c:\talos-slave\test\build\firefox\mozjs.dll
2012-06-23 03:03:03: minidump_processor.cc:116: INFO: Minidump c:\users\cltbld\appdata\local\temp\tmp4zf1if\minidumps\aeb0947d-dabc-477b-af90-1549f0513295.dmp has CPU info, OS info, Breakpad info, exception, module list, thread list, no dump thread, and requesting thread
2012-06-23 03:03:03: minidump_processor.cc:150: INFO: Looking at thread c:\users\cltbld\appdata\local\temp\tmp4zf1if\minidumps\aeb0947d-dabc-477b-af90-1549f0513295.dmp:0/31 id 0x720
2012-06-23 03:03:03: source_line_resolver_base.cc:203: INFO: Loading symbols for module c:\talos-slave\test\build\firefox\mozjs.dll from buffer
2012-06-23 03:03:03: range_map-inl.h:91: INFO: StoreRange failed, an existing range contains or extends higher than the new range: new 0xc28d0+0x1f, existing 0xc28d0+0x1f
2012-06-23 03:03:03: range_map-inl.h:91: INFO: StoreRange failed, an existing range contains or extends higher than the new range: new 0xc2790+0x28, existing 0xc2790+0x28
2012-06-23 03:03:03: range_map-inl.h:91: INFO: StoreRange failed, an existing range contains or extends higher than the new range: new 0xcedd0+0x33, existing 0xcedd0+0x33
2012-06-23 03:03:03: range_map-inl.h:91: INFO: StoreRange failed, an existing range contains or extends higher than the new range: new 0xcd930+0x2d, existing 0xcd930+0x2d
2012-06-23 03:03:03: range_map-inl.h:91: INFO: StoreRange failed, an existing range contains or extends higher than the new range: new 0xa9bb0+0x4b, existing 0xa9bb0+0x4b
2012-06-23 03:03:03: range_map-inl.h:91: INFO: StoreRange failed, an existing range contains or extends higher than the new range: new 0xa4210+0x5b, existing 0xa4210+0x5b
2012-06-23 03:03:03: range_map-inl.h:91: INFO: StoreRange failed, an existing range contains or extends higher than the new range: new 0xb79d0+0x37, existing 0xb79d0+0x37
...
<snip>
...
2012-06-23 03:03:08: simple_symbol_supplier.cc:171: INFO: No symbol file at c:\users\cltbld\appdata\local\temp\tmpvrzv48/ntdll.pdb/F0164DA71FAF4765B8F3DB4F2D7650EA2/ntdll.sym
2012-06-23 03:03:08: simple_symbol_supplier.cc:171: INFO: No symbol file at c:\users\cltbld\appdata\local\temp\tmpvrzv48/kernel32.pdb/1BA64A33475D4E37AFA2653A76541B8B2/kernel32.sym
2012-06-23 03:03:08: minidump_processor.cc:258: INFO: Processed c:\users\cltbld\appdata\local\temp\tmp4zf1if\minidumps\aeb0947d-dabc-477b-af90-1549f0513295.dmp
2012-06-23 03:03:08: minidump.cc:3472: INFO: Minidump closing minidump
      2 [main] minidump_stackwalk 940 exception::handle: Exception: STATUS_ACCESS_VIOLATION
   1668 [main] minidump_stackwalk 940 open_stackdumpfile: Dumping stack trace to minidump_stackwalk.exe.stackdump

minidump_stackwalk exited with return code 35584
Saved dump as c:\talos-slave\test/minidumps\aeb0947d-dabc-477b-af90-1549f0513295.dmp
WARNING | automationutils.processLeakLog() | refcount logging is off, so leaks can't be detected!

INFO | runtests.py | Running tests: end.
program finished with exit code -1073741819
}
Ted, any ideas what is up with the minidump processor in the log in comment 0?
Component: DOM → DOM: Traversal-Range
QA Contact: general → traversal-range
I can't see any way to debug this without a stack trace, line number, disassembly of the instruction the crash occurred at, something.  Since not every pass is printed, I don't even know which test in the file it crashed in.
Super-Ted will save us :-D
It's crashing. I can't discern anything more from the output, but it sounds like a bug in Breakpad. Hard to diagnose without having the minidump file to reproduce it.
Depends on: 768479
Summary: Intermittent crash during test_Range-surroundContents.html | Exited with code -1073741819 during test run → Intermittent crash during test_Range-surroundContents.html | Exited with code -1073741819 during test run (Missing stack)
Depends on: 768489
Whiteboard: [orange] → [orange][badslave?][talos-r3-w7-038]
(In reply to TinderboxPushlog Robot from comment #5)
> bbs
> https://tbpl.mozilla.org/php/getParsedLog.php?id=13201461&tree=Try
> Rev3 Fedora 12x64 try debug test mochitests-2/5 on 2012-07-03 12:08:20
> slave: talos-r3-fed64-032

This is a null dereference in mozilla::storage::VacuumManager::Observe.
This bug was observed only on one or more of the six machines listed in
bug 787281 comment 11, which seem likely to have bad memory, disk, or
other hardware problem, based on the rate of failures on those machines
and the types of failures observed.

Therefore I'm marking this bug invalid, though it should be reopened if
it occurs on other (more reliable) hardware.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → INVALID
Whiteboard: [orange][badslave?][talos-r3-w7-038] → [badslave?][talos-r3-w7-038]
Component: DOM: Traversal-Range → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.