Assertion failure then segfault in xpc:PermitIfUniversalXPConnect

RESOLVED WORKSFORME

Status

()

Core
XPConnect
RESOLVED WORKSFORME
6 years ago
4 months ago

People

(Reporter: miker, Unassigned)

Tracking

(Depends on: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Leave open after merge])

Attachments

(2 attachments)

Created attachment 636286 [details]
stack trace

Assertion failure: !AccessCheck::callerIsChrome(), at /home/ratcliffes/Desktop/FirefoxSource/js/xpconnect/wrappers/AccessCheck.cpp:452

Program received signal SIGSEGV, Segmentation fault.
0xb562aa08 in xpc::PermitIfUniversalXPConnect (cx=0xa75f95f0, id=..., act=js::AbstractWrapper::GET, perm=@0xbfffa16c) at /home/ratcliffes/Desktop/FirefoxSource/js/xpconnect/wrappers/AccessCheck.cpp:452
452	    MOZ_ASSERT(!AccessCheck::callerIsChrome());


I thought that we always called ABRT on failed assertions.
Created attachment 636287 [details] [diff] [review]
Patch used to reproduce the problem

Test case (patch).

1. Apply patch to revision https://hg.mozilla.org/integration/fx-team/rev/e51851dba7a2, build & run
2. Tools -> Web Developer -> Net Monitor

Boom

The patch is incomplete and buggy but it shouldn't raise this assertion.
Ah, this is the other variant of bug 766641. I just pushed a patch to make it non-fatal for now.

http://hg.mozilla.org/integration/mozilla-inbound/rev/7eb665a56c55
Depends on: 766641
Whiteboard: [Leave open after merge]
I am not sure why you want this left open after the merge, it is working fine.
(In reply to Michael Ratcliffe [:miker] [:mratcliffe] from comment #4)
> I am not sure why you want this left open after the merge, it is working
> fine.

Because I just disabled the assertion. The actual bug isn't fixed.
The functions mentioned in comment 0 seem to be gone so I'll mark this as worksforme...
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.