Intermittent crash in test_parse_rule.html [@ proxy_Finalize]

RESOLVED INVALID

Status

()

defect
--
critical
RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: emorley, Unassigned)

Tracking

({crash, intermittent-failure})

Trunk
x86
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [js:t][badslave?][talos-r3-w7-038], crash signature)

(Reporter)

Description

7 years ago
Rev3 WINNT 6.1 mozilla-inbound opt test mochitests-4/5 on 2012-06-24 11:54:51 PDT for push e8a507a0a1a8

slave: talos-r3-w7-038

https://tbpl.mozilla.org/php/getParsedLog.php?id=12955085&tree=Mozilla-Inbound

{
41776 INFO TEST-PASS | /tests/layout/style/test/test_parse_rule.html | #a::before {content: 'This is \\00000a '} - "This is \A " should equal "This is \A "
41777 INFO TEST-PASS | /tests/layout/style/test/test_parse_rule.html | #a::before {content: 'This is\20\a'} - "This is \A " should equal "This is \A "
TEST-UNEXPECTED-FAIL | /tests/layout/style/test/test_parse_rule.html | Exited with code 253 during test run
INFO | automation.py | Application ran for: 0:06:08.876000
INFO | automation.py | Reading PID log: c:\users\cltbld\appdata\local\temp\tmp04rytnpidlog
==> process 1996 launched child process 3844
INFO | automation.py | Checking for orphan process with PID: 3844
TEST-UNEXPECTED-FAIL | automation.py | child process 3844 still alive after shutdown
Downloading symbols from: http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-inbound-win32/1340559883/firefox-16.0a1.en-US.win32.crashreporter-symbols.zip
PROCESS-CRASH | /tests/layout/style/test/test_parse_rule.html | application crashed (minidump found)
Crash dump filename: c:\users\cltbld\appdata\local\temp\tmprpdb_f\minidumps\6f104028-64e1-498a-be5a-37aa2e81eb6f.dmp
Operating system: Windows NT
                  6.1.7600 
CPU: x86
     GenuineIntel family 6 model 23 stepping 10
     2 CPUs

Crash reason:  EXCEPTION_ACCESS_VIOLATION_READ
Crash address: 0xfffffffff230a3f4

Thread 0 (crashed)
 0  mozjs.dll!proxy_Finalize [jsproxy.cpp:e8a507a0a1a8 : 1529 + 0x16]
    eip = 0x72198bf8   esp = 0x0020c9b4   ebp = 0x0020c9c0   ebx = 0x0020ca70
    esi = 0xf230a3f4   edi = 0x34e3d7f0   eax = 0xf230a3f4   ecx = 0x00000004
    edx = 0x34e3ddf0   efl = 0x00210202
    Found by: given as instruction pointer in context
 1  mozjs.dll!js::gc::Arena::finalize<JSObject>(js::FreeOp *,js::gc::AllocKind,unsigned int) [jsgc.cpp:e8a507a0a1a8 : 296 + 0x19]
    eip = 0x7215b276   esp = 0x0020c9c8   ebp = 0x0020c9f4
    Found by: call frame info
 2  mozjs.dll!js::gc::FinalizeTypedArenas<JSObject>(js::FreeOp *,js::gc::ArenaLists::ArenaList *,js::gc::AllocKind) [jsgc.cpp:e8a507a0a1a8 : 343 + 0xf]
    eip = 0x7215b790   esp = 0x0020c9fc   ebp = 0x0020ca1c
    Found by: call frame info
 3  mozjs.dll!js::gc::ArenaLists::finalizeObjects(js::FreeOp *) [jsgc.cpp:e8a507a0a1a8 : 1589 + 0xe]
    eip = 0x7215bbe7   esp = 0x0020ca24   ebp = 0x0020ca50
    Found by: call frame info
 4  mozjs.dll!SweepPhase [jsgc.cpp:e8a507a0a1a8 : 3363 + 0xd]
    eip = 0x7215c12e   esp = 0x0020ca58   ebp = 0x0020ca80
    Found by: call frame info
 5  mozjs.dll!GCCycle [jsgc.cpp:e8a507a0a1a8 : 3793 + 0xd]
    eip = 0x7215c76b   esp = 0x0020ca88   ebp = 0x0020caa8
    Found by: call frame info
 6  mozjs.dll!Collect [jsgc.cpp:e8a507a0a1a8 : 3895 + 0x1a]
    eip = 0x7215c8e0   esp = 0x0020cab0   ebp = 0x0020cacc
    Found by: call frame info
 7  mozjs.dll!js::GCSlice(JSRuntime *,js::JSGCInvocationKind,js::gcreason::Reason) [jsgc.cpp:e8a507a0a1a8 : 3925 + 0x20]
    eip = 0x7215c9a4   esp = 0x0020cad4   ebp = 0x0020caec
    Found by: call frame info
 8  mozjs.dll!js::NotifyDidPaint(JSRuntime *) [jsfriendapi.cpp:e8a507a0a1a8 : 748 + 0x9]
    eip = 0x72152a96   esp = 0x0020caf4   ebp = 0x0020cb04
}
(Reporter)

Updated

7 years ago
Depends on: 768489
Whiteboard: [orange] → [orange][badslave?][talos-r3-w7-038]
Whiteboard: [orange][badslave?][talos-r3-w7-038] → [js:t][orange][badslave?][talos-r3-w7-038]
This bug was observed only on one or more of the six machines listed in
bug 787281 comment 11, which seem likely to have bad memory, disk, or
other hardware problem, based on the rate of failures on those machines
and the types of failures observed.

Therefore I'm marking this bug invalid, though it should be reopened if
it occurs on other (more reliable) hardware.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
Whiteboard: [js:t][orange][badslave?][talos-r3-w7-038] → [js:t][badslave?][talos-r3-w7-038]
You need to log in before you can comment on or make changes to this bug.