Compressing large folders doesn't work

VERIFIED DUPLICATE of bug 66795

Status

VERIFIED DUPLICATE of bug 66795
18 years ago
10 years ago

People

(Reporter: brian, Assigned: mscott)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Build ID: 2001041904

I've noticed this for some time, but haven't figured out exactly how to
reproduce it... appears random except for possibly the number of messages having
an affect.

When moving a mail message to a different folder, or deleting it, the message is
not always properly moved to the corresponding file and removed from the
original one (in the profile's Mail\<servername>\ folder, the Inbox, Sent, etc
files), but the display in Mail/News is correct.  In general, this isn't a
serious problem, except when deleting large numbers of files... For instance, I
have a 75 MB Inbox with 6 messages that actually show up in Mail/News.  I have
emptied the trash, compacted the folders, etc with no change... Trash is now 0
KB, but the Inbox file contains 75 MB of messages (I can see the message source
if I open Inbox in Notepad, etc., but they don't appear in the Inbox in
Mozilla), some of which were deleted, and some moved to other folders.  Sorry I
can't give better detail on this one...
(Reporter)

Comment 1

18 years ago
Seems to be a problem with compressing folders actually, after a little testing. 

When attempting to compress a Mail folder, Mozilla creates an nstmp file that
contains the correct contents of the mail folder, then doesn't replace the mail
folder file with it, but just leaves the mail folder as is.

I have changed the summary to reflect this.
Summary: Move/Delete Message doesn't have proper affect on files → Compressing large folders doesn't work

Updated

18 years ago
QA Contact: esther → sheelar

Comment 2

18 years ago
reporter,
Imap or pop? How are compressing the folder 1. file menu|compact folders? or 
2.compact this folder from the right click menu? 

nsmpt folder appearing when compacting was fixed a while ago.  May be this is 
occuring on win2000 only  

cc naving

Comment 3

18 years ago
buildid:  2001-04-19-04 win98 I compacted inbox which was about 34MB in size and 
did not see any nsmtp folder appear. I deleted about 100 messages and compact 
folders from file menu item.  The size changed and I did get rid of the messages 
in my inbox.  Try to delete your inbox.msf file and let it rebuild.  

stephen,
Do you have a machine running win2000?

Comment 4

18 years ago
I have not been able to reproduce this on win 2k

*** This bug has been marked as a duplicate of 66795 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
Me neither, on build 2001041820 using Windows 2000, on IMAP.

Comment 6

18 years ago
verified as dup
Status: RESOLVED → VERIFIED
(Reporter)

Comment 7

18 years ago
It's a pop account.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.