If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

TouchPal Keyboard deletes entered text when trying to autocomplete first word

VERIFIED FIXED in Firefox 16

Status

()

Firefox for Android
Keyboards and IME
P2
normal
VERIFIED FIXED
5 years ago
a year ago

People

(Reporter: cpeterson, Assigned: cpeterson)

Tracking

16 Branch
Firefox 17
ARM
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox14 unaffected, firefox15+ unaffected, firefox16+ verified, firefox17 verified)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
After you have entered the first word (and a space), autocompleting subsequent words works correctly.

My example assumes your form autocomplete history includes an entry for the word "cat".

STR:
1. Load any page with a text input form. I like using the Firefox Mobile Support page.
2. Type "c"
3. See "c|"
4. Select autocomplete entry "cat"

AR: See "|"
ER: See "cat|"
(Assignee)

Comment 1

5 years ago
We are tracking bug 764193 for Fennec 15. If we want to re-enable the form autocomplete popup for Fennec 15, we should also track this TouchPal autocomplete bug.
tracking-firefox15: --- → ?
tracking-firefox16: --- → ?
(Assignee)

Updated

5 years ago
Status: NEW → ASSIGNED
Tracking as per comment 1
tracking-firefox15: ? → +
tracking-firefox16: ? → +
(Assignee)

Updated

5 years ago
Priority: -- → P2
(Assignee)

Comment 3

5 years ago
Created attachment 642735 [details] [diff] [review]
ignore-empty-composing-events.patch

Ignore empty composing events when we have no composition string to replace.

If the VKB sends us a replacement composition string that is empty and we have no active composition string to replace, then just ignore the empty string. Some VKBs, such as TouchPal Keyboard, send us empty strings at inopportune times, deleting committed text.

This bug is one of the few remaining blockers preventing us from re-enabling form autocomplete (bug 764193).
Attachment #642735 - Flags: review?(blassey.bugs)
Attachment #642735 - Flags: review?(blassey.bugs) → review+
(Assignee)

Comment 4

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/c033e6c7c407
status-firefox17: --- → fixed
(Assignee)

Updated

5 years ago
Target Milestone: --- → Firefox 17
(Assignee)

Comment 5

5 years ago
If we fix bug 764193 (re-enable form autocomplete) in Firefox 16, we should uplift this patch, too.

Comment 6

5 years ago
https://hg.mozilla.org/mozilla-central/rev/c033e6c7c407
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
status-firefox15: --- → affected
status-firefox16: --- → affected
Aurora/Beta nom?
(Assignee)

Comment 8

5 years ago
Comment on attachment 642735 [details] [diff] [review]
ignore-empty-composing-events.patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: Form autocomplete has just be re-enabled on Aurora 16, so it will break badly for TouchPal VKB users if we don't have this fix.
Testing completed (on m-c, etc.): m-c
Risk to taking this patch (and alternatives if risky): Low risk because the code change is just ignoring some empty strings sent from the TouchPal VKB.
String or UUID changes made by this patch: None
Attachment #642735 - Flags: approval-mozilla-aurora?
Comment on attachment 642735 [details] [diff] [review]
ignore-empty-composing-events.patch

Low risk, and we'll need this for re-enabled form autocomplete. Approving.
Attachment #642735 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Comment 10

5 years ago
Firefox 14 and Beta 15 are unaffected because form autocomplete is disabled on those channels.
status-firefox14: --- → unaffected
status-firefox15: affected → unaffected
(Assignee)

Comment 11

5 years ago
https://hg.mozilla.org/releases/mozilla-beta/rev/a6994473b0b4
status-firefox16: affected → fixed
(Assignee)

Comment 12

5 years ago
^^^ Please ignore comment 11. That link points to the wrong changeset and the wrong branch.

This is the correct changeset for Aurora 16:
https://hg.mozilla.org/releases/mozilla-aurora/rev/51701d1f4bcc
(Assignee)

Updated

5 years ago
Blocks: 781020
Verified fix on: Firefox Mobile 16 beta 2, Nightly 18.0a1 2012-09-04 and Aurora 17.0a2 2012-09-04 on Samsung Galaxy Tab 2 7.0 (Android 4.0.4)
Status: RESOLVED → VERIFIED
status-firefox16: fixed → verified
status-firefox17: fixed → verified
You need to log in before you can comment on or make changes to this bug.