Last Comment Bug 768214 - Crash [@ ResolveRelativePath] or [@ js::workers::Worker::create] with Worker in js shell
: Crash [@ ResolveRelativePath] or [@ js::workers::Worker::create] with Worker ...
Status: RESOLVED FIXED
js-triage-needed
: crash, testcase
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: All Mac OS X
: -- critical (vote)
: ---
Assigned To: general
:
:
Mentors:
Depends on:
Blocks: jsfunfuzz
  Show dependency treegraph
 
Reported: 2012-06-25 14:30 PDT by Gary Kwong [:gkw] [:nth10sd]
Modified: 2012-07-05 19:37 PDT (History)
4 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
stacks (2.62 KB, text/plain)
2012-06-25 14:30 PDT, Gary Kwong [:gkw] [:nth10sd]
no flags Details

Description Gary Kwong [:gkw] [:nth10sd] 2012-06-25 14:30:39 PDT
Created attachment 636488 [details]
stacks

evaluate("Worker()", {
  fileName: null
})

crashes the following js shells on m-c changeset 3fe96d84e281 without any CLI arguments.

Opt shell:

https://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-central-macosx64/1340637618/jsshell-mac.zip

Debug shell:

https://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-central-macosx64-debug/1340637618/jsshell-mac64.zip

Stacks do not have symbols because ... tinderbox js shells don't have native symbols likely due to bug 715365.
Comment 1 Gary Kwong [:gkw] [:nth10sd] 2012-07-05 19:37:28 PDT
(actually, FIXED by the removal of Worker, a known patch in bug 771281 - hurray!)

Note You need to log in before you can comment on or make changes to this bug.