Firefox will not restore from task bar

RESOLVED WORKSFORME

Status

()

Firefox
Shell Integration
--
major
RESOLVED WORKSFORME
6 years ago
2 years ago

People

(Reporter: Roger Shaw, Unassigned)

Tracking

13 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2016-04-01])

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20100101 Firefox/13.0.1
Build ID: 20120614114901

Steps to reproduce:

Was using firefox as usual.  But after minimizing Firefox to the taskbar, I could not re-open ANY of the tabs.

I COULD open a new FF window, but never the original.  I tried logging off, then back on - still have the problem.  Had to reboot Windows 7 to correct.

NOTE:  I first saw this problem last night on my notebook computer (Win7).  Tonight I had the same problem on my Dell laptop (XPS L702X - 64 bit).



Actual results:

A brief flash of the FF window, then nothing.


Expected results:

FF should have opened the window showing the select tab/
(Reporter)

Comment 1

6 years ago
FYI: Earlier I had the FF problem detailed in bug 656891 (716459) - Title bar goes black, lose minimize/maximixe/close buttons).  I had exited FF, then restarted.

This problem occurred some time later (an hour?)
(Reporter)

Comment 2

6 years ago
Problem has come back on my notebook...  I cannot get FireFox to open at all.  From the task bar, OR by selecting the FF icon on my desktop.

A window opens briefly, then closes to the task bar, and cannot be re-opened from there.

I un-pinned it from the task bar, closed the FF window (shut down FF), then tried the desktop icon again.  Same problem - opens briefly, then minimizes to the task bar, and cannot be opened.

As of now, I cannot run/access FF at all on my notebook (ASUS Eee computer - running Windows 7).
Severity: normal → major

Comment 3

6 years ago
WFM on:
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:16.0) Gecko/16.0 Firefox/16.0 (20120703041519)

Roger, did this happen to you with older Firefox versions? Can you please try to reproduce it in safe mode or with a clean profile?
Component: Untriaged → General
QA Contact: untriaged → general
(Reporter)

Comment 4

6 years ago
I never saw this before V13.  And it is pretty intermittent...  I have only seen it once on my laptop, and twice on the netbook (the second time, reported yesterday - 07/02 - disappeared after completely shutting down the computer; then rebooting - a 'cold' boot if you will.)

I'll try to duplicated it as requested.
Component: General → Untriaged

Comment 5

6 years ago
Works fine for me in Firefox 13.0.1 and Windows 7.
Component: Untriaged → General
(Reporter)

Comment 6

6 years ago
(In reply to Gabriela from comment #5)
> Works fine for me in Firefox 13.0.1 and Windows 7.


A) I am running V13.0.1 and Windows 7 - problem on 2 different machines

B) What does 'Works fine for me" mean?

   Have you seen the problem with other versions, but not his one?  

       Or, 

   Have you never seen the problem? (In which case, WHY are you writing anything?)
(Reporter)

Comment 7

6 years ago
Problem reappeared on my Netbook (ASUS):

1. Could not open FF from task bar.
2. Rebooted into Safe Mode with Networking.  SAME PROBLEM.
3. Repeated step 2 two more times, same result.
4. Rebooted normally.  Same problem.

5. Right clicked on FF tab, selected 'Open new window'.  It open normally.
6. Right clicked on FF tab, closed the first window (the one that wouldn't open - the 'legacy window', that was present at start-up)

7. Shut the [new] FF window, and reopened several times, no 'problem.
8. Shutdown computer, and restarted in both normal boot and Safe Mode with Networking'.  FF seems to be working again.
(Reporter)

Comment 8

6 years ago
Problem reappeared on Laptop:

As of right now I cannot restore any of my tabbed windows (only got to this window by selected 'Open New Window'. (as reported on 07/08)

However, this time I cannot seem to correct from the error (even rebooting ws no help).

BTW, This is with FireFox V14.0.1
(Reporter)

Comment 9

6 years ago
Also, I cannot restore the 'pinned' tabs that I always use...

Updated

5 years ago
Component: General → Shell Integration
(Reporter)

Comment 10

5 years ago
??

Comment 11

2 years ago
Roger, Do you still see this?
If you do, what happens if you install version 13? 
  http://releases.mozilla.org/pub/firefox/releases/13.0.1/win32/en-US/

There are updates in bug 656891. 
FWIW, the only time I've ever seen this I concluded the problem is Windows, and not Firefox.
Flags: needinfo?(roger)
Whiteboard: [closeme 2016-04-01]
(Reporter)

Comment 12

2 years ago
V13 !!!  I am on Firefox Version 44.0.2

Comment 13

2 years ago
Yes, please "test" v13.  it would be a great help if know this is truely a regression. And since you are the person who can reproduce ...
(Reporter)

Comment 14

2 years ago
Actually, I could never 'reproduce' the problem - not at will.  It seemed totally random, and I never found a reliable way to make it appear.  And I have not seen it for awhile. Probably because I got in the habit of just closing Firefox, then reopening it for every problem I have (and have A LOT - it is often crashing, or slowing down so much that it becomes unusable.  So I just close and reopen it!)

As for testing V13 - it may be awhile - I am about to go on an extended trip, and don't have much time right now (sorry).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(roger)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.