window.open('http://foo', 'test'); window.open('http://bar', 'test'); only opens one window

VERIFIED INVALID

Status

()

--
major
VERIFIED INVALID
18 years ago
18 years ago

People

(Reporter: darkshadow, Assigned: jst)

Tracking

Trunk
x86
Other
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
1. Go to: http://mozilla.org/quality/help/bugzilla-helper.html and make a
bugzilla query. The results will be opened in a new window.
2. open kde.org in this window (or another site)
3. got to the first window, and start another query.

==>It won't open a new window, it will use the second one I already used for
browsing on other sites.

used version: daily build from 18/04/2001 - 2001041804
Platform: win 98, maybe others too
The code that opens the window:

window.open( searchURL, "other" );

Looks like a window.open() will not open a new window if a window with the name
it's passed already exists.... This seems wrong somehow... but Netscape 4.x does
the same.

reassigning to DOM0
Assignee: asa → jst
Status: UNCONFIRMED → NEW
Component: Browser-General → DOM Level 0
Ever confirmed: true
QA Contact: doronr → desale
Summary: Mozilla opens URL in wrong window → window.open('http://foo', 'test'); window.open('http://bar', 'test'); only opens one window

Comment 2

18 years ago
This is correct behaviour as it is the only possibility to open URLs in one
(always the same) new window. If you want to open URLs in multiple different
windows use window.open(URL, '_blank');
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID

Comment 3

18 years ago
Stephan is right.
Invalid verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.