Bug with Firefox and a Flash player which has "hide mouse" feature

RESOLVED WORKSFORME

Status

External Software Affecting Firefox
Flash (Adobe)
P3
normal
RESOLVED WORKSFORME
5 years ago
3 years ago

People

(Reporter: Erwann Mest, Unassigned)

Tracking

({flashplayer})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [flash-11.3][flash-11.4], URL)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:13.0) Gecko/20100101 Firefox/13.0.1
Build ID: 20120614114901

Steps to reproduce:

I'm on my MacBook Pro Lion 10.7.4 with Firefox 13.0.1 and Flash 11,3,300,257.

I'm on this page: http://www.canalplus.fr/c-divertissement/pid3351-c-le-petit-journal.html?vid=682402 with the player sticked to the firefox top bar. 


Actual results:

If I let my mouse on the flash, this flash player hides my mouse. But when I want to go out of the flash going to the top bar, the flash doesn't recognize I'm not on the flash anymore and still continue to hide my mouse after few seconds. I've got the same problem if I change the space where I am with firefox to another one (Lion feature).

This bug doesn't happen on webkit. It seems to be a particular bug between and firefox.

Plus, It ain't this video flash player the problem, because I've got the same bug with another flash player which has hide mouse feature.

To not have the bug, I need to quit the flash player but still stay on the display container (where firefox displays the website). It's like the event "mouse leave" is only played on the display container.
(Reporter)

Updated

5 years ago
Hardware: x86 → x86_64
(Reporter)

Updated

5 years ago
Keywords: flashplayer
(Reporter)

Updated

5 years ago

Updated

5 years ago
Component: Untriaged → Flash (Adobe)
Product: Firefox → Plugins
QA Contact: untriaged → adobe-flash
Version: 13 Branch → unspecified
Whiteboard: [flash-11.3]

Comment 1

5 years ago
I've tried this using the steps from the description on:
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:13.0) Gecko/20100101 Firefox/13.0.1

and indeed, with Flash 11.3.300.257 the issue is reproducing for me: play a video and leave the mouse cursor over it. After a few seconds the cursor will disappear, start scrolling the page and the mouse cursor will disappear all together.

With Flash 11.4.400.231 this is not the case so it's working fine
(Reporter)

Comment 2

5 years ago
I've got now Flash 11,4,400,252 installed and still have the trouble.

Comment 3

5 years ago
Build ID: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:13.0) Gecko/20100101 Firefox/13.0.1

I've also tried with Flash 11.4.400.252 and with the steps from comment1, the issue is not reproducing on that site, hoever if I let the clip play and open the Addons Manager from the menu in a new tab the mouse will disappear after a few seconds.

This obviously isn't the right behavior.

Setting the resolution to NEW.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

5 years ago
Same thing is happening on:
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:15.0) Gecko/20100101 Firefox/15.0 beta 3

Updated

5 years ago
Whiteboard: [flash-11.3] → [flash-11.3][flash-11.4]
(Reporter)

Comment 5

4 years ago
Any help? Still here after 1 year.
(Reporter)

Comment 6

4 years ago
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:27.0) Gecko/20100101 Firefox/27.0 with Flash 11.9.900.152
The original video is gone and i don't see any mouse hiding on [1] (whether the Flash element is focused or not) with the current Nightly, Flash 11.9.900.117, OS X 10.8.
Focus events are delivered fine for [1]. This sounds rather similar to bug 717340.

[1] http://www.canalplus.fr/c-divertissement/c-le-petit-journal/pid6381-les-extraits.html?vid=971918
Priority: -- → P3
(Reporter)

Comment 8

4 years ago
The url was just an example. It does that on all flash which use mouse hiding

Steps:

- Go on this page: http://playtv.fr/television/france-2/
- Wait the ads, you'll see the player.
- Scroll your webview to have the player sticked to the address bar
- Move your mouse on the player
- Wait until your mouse is hidden
- Now quit the player with the mouse by moving it into the address bar, the mouse DO NOT have to go somewhere else in the webview, it must go from flash to address bar (or something which is not the webview)
- Wait a bit, you'll see your mouse to be hidden

The flash doesn't understand that you quit its context in fact and triggers the mouse hiding.
(Reporter)

Comment 9

4 years ago
flashes*
DOES NOT*
sorry.
(Reporter)

Comment 10

4 years ago
Oh and if you quit the tab which has the flash which has the mouse hiding feature, it gets your mouse back.
playtv.fr is region restricted, but i can reproduce with a canalplus.fr video [1]:
* scroll video so that there is no other page content between video and location bar
* play video, exit and enter mouse to some page content to the sides => NPCocoaEventMouseExited/Entered are send
* exit mouse cursor to the location (i.e. without going over other page content) => no Exited event
* reenter video from location => no Entered event

So apparently we only send Exited/Entered events here when moving between plugin and DOM elements, but not when moving between the plugin and other UI.

[1] http://www.canalplus.fr/c-divertissement/c-le-petit-journal/pid6381-les-extraits.html?vid=971918
(Reporter)

Comment 12

4 years ago
Thank you Georg (and sorry for the region restricted).
Georg, you might want to also test with my Debug Events Plugin from bug 441880, just to make sure this problem isn't Flash-specific.
(In reply to Steven Michaud from comment #13)
> Georg, you might want to also test with my Debug Events Plugin from bug
> 441880, just to make sure this problem isn't Flash-specific.

This didn't build immediately for me, but i see exactly the same behavior with our test plugin.
> This didn't build immediately for me

I haven't updated the build system in a long time.  It's possible it no longer builds with current versions of XCode.  But you should still be able to run the (bundled) executable :-)

However, if you can reproduce this bug with our test plugin, you've already found out this bug isn't specific to Flash.
(Reporter)

Comment 16

4 years ago
What's up with this 2-years-old bug? It still happens and makes me sad.
(Reporter)

Comment 17

4 years ago
Can I do something to help you to fix it?
This bug still needs someone who has time to investigate & debug further.
Maybe Steven can provide good entry points here where to start checking what happens?
Flags: needinfo?(smichaud)
The only advice I can give I already gave above:  Someone needs to test with my Debug Events Plugin from bug 441880.

I haven't updated it in a long time, and it doesn't build with current versions of XCode.  But the download does contain a pre-built binary.
Flags: needinfo?(smichaud)
(In reply to Steven Michaud from comment #19)
> The only advice I can give I already gave above:  Someone needs to test with
> my Debug Events Plugin from bug 441880.
> 
> I haven't updated it in a long time, and it doesn't build with current
> versions of XCode.  But the download does contain a pre-built binary.

Per comment 14 i already confirmed this happening with our test plugins as well - does the Debug Events Plugin offer any additional information?
(In reply to comment #20)

I frankly don't know ... but try it and see :-)

By the way, this bug might have been fixed by the patch for bug 995603, which landed on the trunk (the 32 branch) as of the 2014-05-12 nightly, and subsequently on the alpha (31) and beta (30) branches.

If it doesn't, please give detailed and current STR.
Indeed, a quick check shows that i can't reproduce anymore.

Erwann, can you check with a Firefox Nigthly and confirm?
http://nightly.mozilla.org/
Flags: needinfo?(m+bugzilla)
(Reporter)

Comment 23

3 years ago
32.0a1 (2014-06-02) here, seems to be fixed. Thank you. ;)
Nice, thanks for the confirmation.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(m+bugzilla)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.