If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Intermittent crash in browser_gcli_edit.js [@ libxul.so@0x135e475]

RESOLVED DUPLICATE of bug 768045

Status

()

Firefox
Developer Tools
--
critical
RESOLVED DUPLICATE of bug 768045
5 years ago
5 years ago

People

(Reporter: emorley, Unassigned)

Tracking

({crash, intermittent-failure})

15 Branch
x86
Linux
crash, intermittent-failure
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

5 years ago
Rev3 Fedora 12 mozilla-aurora pgo test mochitest-other on 2012-06-24 05:27:22 PDT for push e967f0934767

slave: talos-r3-fed-055

https://tbpl.mozilla.org/php/getParsedLog.php?id=12950892&tree=Mozilla-Aurora

{
TEST-START | chrome://mochitests/content/browser/browser/devtools/commandline/test/browser_gcli_edit.js
TEST-INFO | chrome://mochitests/content/browser/browser/devtools/commandline/test/browser_gcli_edit.js | Console message: [JavaScript Error: "out of memory"]
TEST-INFO | chrome://mochitests/content/browser/browser/devtools/commandline/test/browser_gcli_edit.js | Console message: [JavaScript Error: "TypeError: this._scripts is null" {file: "resource://gre/modules/devtools/dbg-client.jsm" line: 422}]
TEST-INFO | chrome://mochitests/content/browser/browser/devtools/commandline/test/browser_gcli_edit.js | Console message: [JavaScript Error: "this._actorPool is null" {file: "chrome://global/content/devtools/dbg-server.js" line: 397}]
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/commandline/test/browser_gcli_edit.js | Exited with code 1 during test run
INFO | automation.py | Application ran for: 0:10:21.590333
INFO | automation.py | Reading PID log: /tmp/tmpayLdo1pidlog
==> process 2474 launched child process 2524
INFO | automation.py | Checking for orphan process with PID: 2524
Downloading symbols from: http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-aurora-linux/1340536807/firefox-15.0a2.en-US.linux-i686.crashreporter-symbols.zip
PROCESS-CRASH | chrome://mochitests/content/browser/browser/devtools/commandline/test/browser_gcli_edit.js | application crashed (minidump found)
Crash dump filename: /tmp/tmprYqynL/minidumps/3b6f896e-d514-2bd2-3a59f94e-5bf42fd5.dmp
Operating system: Linux
                  0.0.0 Linux 2.6.31.5-127.fc12.i686.PAE #1 SMP Sat Nov 7 21:25:57 EST 2009 i686
CPU: x86
     GenuineIntel family 6 model 23 stepping 10
     2 CPUs

Crash reason:  SIGSEGV
Crash address: 0x1a4

Thread 0 (crashed)
 0  libxul.so + 0x135e475
    eip = 0x022f2475   esp = 0xbf8733e0   ebp = 0xbf8735ac   ebx = 0x0284ad28
    esi = 0xb3f15000   edi = 0x00000000   eax = 0x00000000   ecx = 0xb8b85480
    edx = 0x00000000   efl = 0x00010246
    Found by: given as instruction pointer in context
 1  0xbf8700ff
    eip = 0xbf870100   esp = 0xbf8735b4   ebp = 0xb8ad3f10
    Found by: previous frame's frame pointer
 2  libxul.so + 0x18a9bef
    eip = 0x0283dbf0   esp = 0xbf8735b8   ebp = 0xb8ad3f10
    Found by: stack scanning
 3  libxul.so + 0xf89b78
    eip = 0x01f1db79   esp = 0xbf8735c0   ebp = 0xb8ad3f10
    Found by: stack scanning
 4  libxul.so + 0x18b6d27
    eip = 0x0284ad28   esp = 0xbf8735e0   ebp = 0xb8ad3f10
    Found by: stack scanning
 5  libxul.so + 0x436d83
    eip = 0x013cad84   esp = 0xbf8735f0   ebp = 0xb8ad3f10
    Found by: stack scanning
 6  ld-2.11.so + 0x114d2
    eip = 0x00ad74d3   esp = 0xbf873608   ebp = 0xb8ad3f10
    Found by: stack scanning
 7  libxul.so + 0xc121af
    eip = 0x01ba61b0   esp = 0xbf873610   ebp = 0xb8ad3f10
    Found by: stack scanning
 8  libxul.so + 0xfd5823
    eip = 0x01f69824   esp = 0xbf873620   ebp = 0xb8ad3f10
    Found by: stack scanning
 9  libxul.so + 0xfaaf74
    eip = 0x01f3ef75   esp = 0xbf87362c   ebp = 0xb8ad3f10
    Found by: stack scanning
10  libxul.so + 0x8df677
    eip = 0x01873678   esp = 0xbf873634   ebp = 0xb8ad3f10
    Found by: stack scanning
11  libxul.so + 0x38fd0d
    eip = 0x01323d0e   esp = 0xbf873640   ebp = 0xb8ad3f10
    Found by: stack scanning
12  libxul.so + 0x18a9bef
}
(Reporter)

Comment 1

5 years ago
Actually, I missed the OOM higher up in the log, think maybe dupe of bug 768045. Leaving open for someone else to confirm.
Depends on: 768534
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 768045
(Assignee)

Updated

5 years ago
Keywords: intermittent-failure
(Assignee)

Updated

5 years ago
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.