Closed Bug 768560 Opened 10 years ago Closed 1 year ago

crash in nsCSSFrameConstructor::AddFrameConstructionItemsInternal mainly with AMD Radeon HD 6xxx series

Categories

(Core :: Layout, defect)

14 Branch
x86
Windows 7
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: scoobidiver, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: crash, regression)

Crash Data

It's high in 14.0b9 and likely related to bug 714320 and bug 768383.

The first frames of the stack trace look like:
Frame 	Module 	Signature 	Source
0 		@0xaf06400 	
1 	xul.dll 	nsCSSFrameConstructor::ResolveStyleContext 	layout/base/nsCSSFrameConstructor.cpp:4562
2 	xul.dll 	nsCSSFrameConstructor::BuildInlineChildItems 	layout/base/nsCSSFrameConstructor.cpp:10920
3 	xul.dll 	nsCSSFrameConstructor::AddFrameConstructionItemsInternal 	layout/base/nsCSSFrameConstructor.cpp:5241
4 	xul.dll 	nsCSSFrameConstructor::AddFrameConstructionItems 	layout/base/nsCSSFrameConstructor.cpp:5007
5 	xul.dll 	nsCSSFrameConstructor::ProcessChildren 	layout/base/nsCSSFrameConstructor.cpp:9588
6 	xul.dll 	nsCSSFrameConstructor::ConstructBlock 	layout/base/nsCSSFrameConstructor.cpp:10650

Frame 	Module 	Signature 	Source
0 		@0xab84500 	
1 	xul.dll 	nsCSSFrameConstructor::BuildInlineChildItems 	layout/base/nsCSSFrameConstructor.cpp:10920

Frame 	Module 	Signature 	Source
0 	xul.dll 	nsXBLService::LoadBindings 	content/xbl/src/nsXBLService.cpp:569
1 	xul.dll 	nsCSSFrameConstructor::AddFrameConstructionItemsInternal 	layout/base/nsCSSFrameConstructor.cpp:5064
2 	xul.dll 	nsCSSFrameConstructor::AddFrameConstructionItems 	layout/base/nsCSSFrameConstructor.cpp:5007
3 	xul.dll 	nsCSSFrameConstructor::CreateGeneratedContentItem 	layout/base/nsCSSFrameConstructor.cpp:1719

More reports at:
https://crash-stats.mozilla.com/report/list?signature=nsCSSFrameConstructor%3A%3AResolveStyleContext%28nsStyleContext*%2C+nsIContent*%2C+nsFrameConstructorState*%29
https://crash-stats.mozilla.com/report/list?signature=nsCSSFrameConstructor%3A%3ABuildInlineChildItems%28nsFrameConstructorState%26%2C+nsCSSFrameConstructor%3A%3AFrameConstructionItem%26%29
https://crash-stats.mozilla.com/report/list?signature=nsXBLService%3A%3ALoadBindings%28nsIContent*%2C+nsIURI*%2C+nsIPrincipal*%2C+bool%2C+nsXBLBinding**%2C+bool*%29
There are no crashes in 14.0b10.
Depends on: 772330
Crash Signature: , nsCSSFrameConstructor::FrameConstructionItem&)] [@ nsXBLService::LoadBindings(nsIContent*, nsIURI*, nsIPrincipal*, bool, nsXBLBinding**, bool*)] → , nsCSSFrameConstructor::FrameConstructionItem&)] [@ nsXBLService::LoadBindings(nsIContent*, nsIURI*, nsIPrincipal*, bool, nsXBLBinding**, bool*)] [@ nsCSSFrameConstructor::ResolveStyleContext] [@ nsCSSFrameConstructor::BuildInlineChildItems] [@ nsXBL…

Closing because no crashes reported for 12 weeks.

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.