Thunderbird 13 mishandles xmodmap keymappings under Linux

UNCONFIRMED
Unassigned

Status

UNCONFIRMED
6 years ago
3 years ago

People

(Reporter: david.burleigh, Unassigned)

Tracking

13 Branch
x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:13.0) Gecko/20100101 Firefox/13.0.1
Build ID: 20120615112143

Steps to reproduce:

I use xmodmap to redefine the right Ctrl key to function as  Del key. I've been using this mapping for years, and it has worked fine for all versions of Thunderbird through 12.0.1. 


Actual results:

When I upgraded to Thunderbird 13.0.1, my remapped right Ctrl key no longer works within Thunderbird to delete messages from the Inbox (for example). I have to click the Delete button on the button bar instead. When composing a message, however, my remapped Ctrl key is taken as Ctrl-Del, that is, it deletes a whole word, rather than a single character.


Expected results:

When I press my right Ctrl key, which is remapped with xmodmap to function as the Del key, it should delete the highlighted message if I'm in the InBox (for example), and when composing a message, it should delete a single character. This is how it worked in Thunderbird 12.0.1 and all previous versions.
(Reporter)

Comment 1

6 years ago
Here is the keymapping I set via xmodmap:

! Make the right Control key duplicate the Del key
keycode 105 = Delete

Comment 2

6 years ago
(In reply to David Burleigh from comment #1)
> Here is the keymapping I set via xmodmap:
> 
> ! Make the right Control key duplicate the Del key
> keycode 105 = Delete

Maybe when you launch Thunderbird your keymapping is overridden. Can you try to remap it after you launch Thunderbird?
(Reporter)

Comment 3

6 years ago
I have tried it both ways, and it is the same, and besides, the keymapping continues to work fine in every other application. 

Right now I am using the "keyconfig" extension for Thunderbird to get around at least part of the problem. But it is revealing because when I set the key for the delete-message action (in the keyconfig dialog box) by pressing the right-Ctrl key (which was remapped in xmodmap to function as the Del key), keyconfig sees it as Ctrl-Del rather than Del.

As I said, even though Thunderbird gets it wrong, every other application (except Firefox) gets it right -- my remapped right-Ctrl key has the function of the Del key. And Thunderbird 12.0.1 also gets it right.

Updated

6 years ago
Component: General → Untriaged

Comment 4

6 years ago
I still have this issue with both Firefox 17 and Thunderbird 17, and only those applications.

I remapped my right Windows key to AltGr because my keyboard does not have one; it makes writing some characters in Firefox or Thunderbird a pain as I have to copy/paste them.

My .Xmodmap:
! KBC Poker mappings
! Right Windows key to Alt Gr
remove Mod4 = Super_R
add Mod5 = Super_R

Comment 5

6 years ago
I can confirm this bug.

I have remapped my right control key with:

xmodmap -e 'keycode 105 = slash question'

which works on every application except firefox and thunderbird.

I'm not sure what keys are being grabbed instead of slash/question. When I'm inside forms, Control_R selects the whole text in the form. Shift+Control_R gives me nothing. Anyway I should be getting slash and question respectively.

Not sure either at what version did this issue started to hit. I'm running 17 but I'm pretty sure it was there at least since version 15, probably before.

I'll try remapping any other key to see how it goes, but this is definitly a bug already.

Comment 6

6 years ago
Looks like bugs 610988 and 770701 are very similar to this one.

I have succesfully remapped my 4 key to 'u U' and later on to 'slash question', and it worked as expected, both times, both in firefox and thunderbird. This was done via xmodmap.

So it really seems, as in the other mentioned bug reports, the bug only affects remapping of Modifier Keys, not regular character input keys.

It's still a bug affecting those of us in need of an extra character input key for whatever reason.

Comment 7

6 years ago
I just wonder what does it take to change the status of this bug to CONFIRMED. As few people as it may affect, it's still a bug, and it's been there for some time now. Besides, it's awfully easy to reproduce. Please would someone care to change this?
You need to log in before you can comment on or make changes to this bug.