If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Text field (to enter email address) looks like it can't be edited (but it can) (15.0a2)

RESOLVED DUPLICATE of bug 769405

Status

()

Core
Layout: Form Controls
RESOLVED DUPLICATE of bug 769405
5 years ago
4 years ago

People

(Reporter: simon@simgrant.info, Unassigned)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:15.0) Gecko/20120626 Firefox/15.0a2
Build ID: 20120626042007

Steps to reproduce:

visited this link: http://www.mozilla.org/en-US/firefox/aurora/ and tried to sign up for newsletter using Aurora 15.0a2 (2012-06-26). 


Actual results:

Cursor did not appear in box. Also couldn't select "Your email address" to highlight for copying to clipboard. If I started typing the "Your email address" disappeared and what I typed did appear (but no cursor). Was still able to submit my email address and sign up for newsletter but it was confusing as at first I thought I couldn't. This issue occurs in Aurora and Nightly(16) but not Stable(13) or Beta(14).


Expected results:

"Your email address" should have disappeared as soon as cursor placed in box. Should have been seen a cursor to indicate field was editable.
(Reporter)

Updated

5 years ago
Confirmed this happens in latest-mozilla-central on Linux as well.
Status: UNCONFIRMED → NEW
Component: Untriaged → DOM: Core & HTML
Ever confirmed: true
Keywords: regressionwindow-wanted
OS: Windows XP → All
Product: Firefox → Core
QA Contact: untriaged → general
Hardware: x86 → All
Version: 15 Branch → Trunk
Simon, can you please investigate using progressively earlier versions of Aurora to find a regression window for this bug? We need to narrow down the exact day where this started to happen. Thanks.
Component: DOM: Core & HTML → Layout: Form Controls
QA Contact: general → layout.form-controls
(Reporter)

Comment 3

5 years ago
(In reply to Anthony Hughes, Mozilla QA (irc: ashughes) from comment #2)
> Simon, can you please investigate using progressively earlier versions of
> Aurora to find a regression window for this bug? We need to narrow down the
> exact day where this started to happen. Thanks.

I confirmed this happens in 15.0a1 but I am not sure where to get an earlier build of 15. Can you point me to URL to download earlier builds of 15? I have already confirmed this is not present in the latest 14 (Beta).

Regards, Simon.
https://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2012/ (by year/month)

(Note that every six weeks code moves from mozilla-central to mozilla-aurora, mozilla-aurora to mozilla-beta, and mozilla-beta to mozilla-release, pretty much simultaneously.  So to track down builds of 15, you'd look at mozilla-aurora builds from now back to June 5 or so, and mozilla-central before that.  The version number is in the filenames.)
(Reporter)

Comment 5

5 years ago
I have found the regression: Portable zip downloaded from ftp://ftp.mozilla.org/pub/firefox/nightly/2012/05/2012-05-25-03-05-17-mozilla-central/firefox-15.0a1.en-US.win32.zip doesn't have regression whereas ftp://ftp.mozilla.org/pub/firefox/nightly/2012/05/2012-05-25-07-02-45-mozilla-central/firefox-15.0a1.en-US.win32.zip does have regression.

Can someone double check this?

Regards, Simon Grant.
Last Good:
Mozilla/5.0 (X11; Linux x86_64; rv:15.0) Gecko/15.0 Firefox/15.0a1 ID:20120525030517
http://hg.mozilla.org/mozilla-central/rev/1dd0c5c6d9fd

First Bad:
Mozilla/5.0 (X11; Linux x86_64; rv:15.0) Gecko/15.0 Firefox/15.0a1 ID:20120525070245
http://hg.mozilla.org/mozilla-central/rev/3871d6ca5fb2

Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=1dd0c5c6d9fd&tochange=3871d6ca5fb2

Potential Bugs:
Bug 673873 - Display placeholder when focusing empty input
Keywords: regressionwindow-wanted → regression
Thanks Simon for helping me track down the regression.
Sounds like the behavior is exactly what it should be, given the markup on the site and the desired behavior in bug 673873.  The only issue I see here is the lack of a caret in the textfield, right?  Mounir?
(In reply to Boris Zbarsky (:bz) from comment #8)
> Sounds like the behavior is exactly what it should be, given the markup on
> the site and the desired behavior in bug 673873.  The only issue I see here
> is the lack of a caret in the textfield, right?  Mounir?

Actually, there is a caret. It's just black so we can't see it.
Duplicate of this bug: 769405
Blocks: 737786

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 769405
You need to log in before you can comment on or make changes to this bug.