css-valid reftest failures with DLBI

RESOLVED FIXED in mozilla16

Status

()

Core
Layout
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: mattwoodrow, Assigned: mattwoodrow)

Tracking

unspecified
mozilla16
x86
Mac OS X
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
This appears to be a regression from bug 764117, hidden by the fact that the tests aren't using MozReftestInvalidate.

Adding MozReftestInvalidate to these tests causes them to fail on trunk, and backing out bug 764117 fixes them.

Paint timing issues with DLBI cause these to fail more frequently. Will attach a patch marking these tests as fuzzy
(Assignee)

Comment 1

5 years ago
Created attachment 637324 [details] [diff] [review]
Convert tests to use MozReftestInvalidate and mark them fuzzy

I think we should land these test fixes, along with marking them fuzzy so that it doesn't block DLBI.

Bas can then decide what to do about them from there.

Note that this bug appears to be triggered by painting the borders twice instead of just once. We were just getting lucky previously and modifying the test case before the first paint. Adding MozReftestInvalidate forces two separate paints.

This suggests some sort of additive effects, but that doesn't really make sense since we should be painting an opaque background first.
Attachment #637324 - Flags: review?(roc)
Maybe it's related to a combination of:

 * nsDisplayBackground::GetOpaqueRegion saying the background is opaque

 * the optimization in nsCSSRendering::PaintBackgroundWithSC that calls IsOpaqueBorder(), and when it's true, changes background-clip:border to background-clip:padding

 * the new border drawing code not actually being fully opaque in cases where said IsOpaqueBorder()  function thinks borders should be opaque

?
(Assignee)

Comment 3

5 years ago
I think that could be it. I was thinking the page would also have a white background behind, but that isn't necessarily in the same layer as the 'opaque' border.
Attachment #637324 - Flags: review?(roc) → review+
(Assignee)

Comment 4

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/d14ec506f28f
https://hg.mozilla.org/mozilla-central/rev/d14ec506f28f
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla16

Comment 6

5 years ago
Backed out (see bug 539356 comment 337):
https://hg.mozilla.org/integration/mozilla-inbound/rev/d3f86e3a3240

Comment 7

5 years ago
https://hg.mozilla.org/mozilla-central/rev/a736bb8d45aa

Updated

5 years ago
Assignee: nobody → matt.woodrow
You need to log in before you can comment on or make changes to this bug.