Closed Bug 768798 Opened 9 years ago Closed 9 years ago

The page doesn't bounce back after sliding it

Categories

(Firefox for Android Graveyard :: General, defect)

16 Branch
ARM
Android
defect
Not set
normal

Tracking

(firefox14 unaffected, firefox15 unaffected, firefox16 verified, firefox17 verified)

VERIFIED FIXED
Firefox 16
Tracking Status
firefox14 --- unaffected
firefox15 --- unaffected
firefox16 --- verified
firefox17 --- verified

People

(Reporter: paul.feher, Assigned: kats)

References

Details

Attachments

(3 files)

Attached image Screenshot
Nightly Fennec 16.0a1 (2012-06-26)
Device: HTC Desire Z 
OS: Android 2.3.3

Steps to Reproduce:
1. Load about:firefox
2. Tap-hold and slide the page until the black background appears.
3. Tap on the page before it bounce back.

Expected:
The page bounce back to the initial position.

Actual:
The page remains slided and the black background is still present.

NOTE: Please see the attached log and screenshot
Attached file Log file
Kats does this log look useful?
Unfortunately we took a lot of the logging out of the code so there isn't too much useful in the log. However I can reproduce this locally so I'll take a look.
Assignee: nobody → bugmail.mozilla
This is fallout from bug 756474, by the removal of the block of code in TouchEventHandler.dispatchEvent. Before that change, the ACTION_UP event would get sent to the PanZoomController, but now it gets eaten by the mGestureDetector. Note that when the code was originally written (prior to bug 707571 landing), there was no onSingleTapUp method in PanZoomController, so the mGestureDetector would not eat the ACTION_UP event. Bug 707571 added the onSingleTapUp along with the code in TouchEventHandler.dispatchEvent that effectively cancelled it out.

Patch coming shortly.
Attached patch PatchSplinter Review
The main change needed is to always return false from onSingleTapUp so that it doesn't eat the ACTION_UP event. To make things consistent I also modified onSingleTapConfirmed and onDoubleTap so that they always return true. This is more or less what it used to be like prior to bug 707571, but with the extra allowZoom() guards on the events.
Attachment #637718 - Flags: review?(mbrubeck)
Attachment #637718 - Flags: review?(mbrubeck) → review+
https://hg.mozilla.org/mozilla-central/rev/032188386b9e
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Verified on:
Nightly Fennec 17.0a1 (2012-08-27)
Device: HTC Desire Z 
OS: Android 2.3.3
Status: RESOLVED → VERIFIED
Unable to reproduce the issue on:

Firefox Mobile 16.0b5
HTC Desire Z (Android 2.3.3)

Marking as verified on Firefox Mobile 16.
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.