Closed Bug 768877 Opened 8 years ago Closed 3 years ago

Wrong From address selected when replying to self

Categories

(Thunderbird :: Message Reader UI, defect)

13 Branch
x86_64
Linux
defect
Not set
minor

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: a.nielsen, Unassigned)

References

(Blocks 1 open bug)

Details

When replying to an e-mail sent to your non-default address, the From field is automatically set to match, so you reply back using the same address you were initially contacted with.

However if you then reply to that mail you just sent (e.g. to add a followup) the From field is not adjusted and incorrectly remains as your default account.

It seems that when replying and trying to figure out which 'from' address to set, TB only looks in the 'to' field to find a matching account.  I think it should also look in the 'from' field, to catch these cases where you are replying to your own e-mail.

Steps to reproduce:

1. Send yourself an e-mail to an alternate address you can read in TB.  Observe the 'from' address while composing is your default address.

2. Reply to this e-mail.  Observe the 'from' address while composing is *not* your default address, but your alternate one - i.e. you are replying back from the address you were contacted on, as expected.

3. Reply to this message you just sent (i.e. the one in your 'sent' folder.)  Observe the 'from' address is now your default address again, even though this default address may not even have been used anywhere in the conversation.
(In reply to Adam Nielsen from comment #0)
This is a duplicate of bug 377998.
(In reply to Hashem Masoud from comment #1)
> (In reply to Adam Nielsen from comment #0)
> This is a duplicate of bug 377998.

That would be pretty hard considering 377998 was fixed in 3.0 and this bug is filed against 13.  So this is either gone or perhaps bug 327713 which is still open.

But if I understand comment 0 correctly I cannot reproduce this?
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → WORKSFORME
Reply-to-self is a can of worms. Magnus fixed bug 903390. What happens also depends on where the message is stored and whether mailnews.reply_to_self_check_all_ident is set.
You need to log in before you can comment on or make changes to this bug.