Firefox made the recordings of my performances on my website for listening only, available to be downloaded and copied by anyone.

RESOLVED INVALID

Status

()

RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: dbanat, Unassigned)

Tracking

12 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:12.0) Gecko/20100101 Firefox/12.0
Build ID: 20120420145725

Steps to reproduce:

A classical violinist, I have a website including my live performances of my concert career. Unlike other browsers, Firefox took up to a minute to play my music on Macs.
 


Actual results:

Now, after an "upgrading," instead of playing the recordings, downloads them to the desktop, thus making them available WITHOUT MY PERMISSION to be copied and distributed at will. Before I seek legal advice for what I trust you will agree is a serious infraction of my professional integrity, I would like your assurance that you intend to fix it.


Expected results:

It should be playing the music selected promptly like on other browsers such as Safari directly from the website without allowing it to be downloaded.  Awaiting your reply and prompt action,  Gabriel Banat.

Updated

6 years ago
Duplicate of this bug: 768967

Comment 2

6 years ago
Right-click in Safari and select "download linked file" and you will get the same result. 

Should be: INVALID
I don't understand your issue.
You can always download any resource that you put on a http server.
A browser could hand over content to a plugin to let it play by this plugin.
That doesn't mean that a user can not simply download the content.

A valid bug report would look like:
I have music and Firefox doesn't play it and instead I get a save as dialog.
The server sends the music with the content-type=x and I have a plugin that supports playing content-type=x. Expected result: The plugin should be used

marking invalid
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
>That doesn't mean that a user can not simply download the content.
An example is http://youtube.com
You can watch videos there but it's no problem to download the videos, watch or edit them on your local system or extract the audio from it.
There is no hacking involved with this just a little bit knowledge.
Where is your website? I too would like to listen to your music!
(Reporter)

Comment 6

6 years ago
Matti, It was the same bug, I left stuff out of the first one, such as the name of the website.  What I want is for it to just play when you click it.  Also, how do I stop it from being downloaded?  Is it possible?  Thanks
>What I want is for it to just play when you click it.
Simple question but difficult answer !
Until recently no browser supported playing Audio without Plugin.
While OSX users have usually quicktime installed with audio/mp3 support this is not true for people on other OS. The only plugin that most people have installed across different OS is Flash.
Modern browsers support the <audio> Tag but the codec isn't specified.
There is unfortunately no codec that is supported by all browsers.

Webm Audio: supported by Firefox, Chrome, Opera
Ogg Vorbis: Firefox, Chrome, Opera
AAC/mp3: Safari, IE

You would have the file in 2 formats and offer the browser both. The browser will pick the supported one.
- https://developer.mozilla.org/En/Media_formats_supported_by_the_audio_and_video_elements

>Also, how do I stop it from being downloaded?
You can use the object tag or audio tag
The user wouldn't get the save as dialog but rather only a not available/missing plugin warning)
Note: A user still can download such a file if he wants to.
(Reporter)

Comment 8

6 years ago
Matti,
The music comes on immediately on Safari, and after a long wait on Firefox. Could that time be eliminated?  Even though it can be downloaded by experts, we will try to make it harder for ordinary people by learning how to use your object or audio tag.  It seems to be just one of our computers (the newest Mac) that won't play it when clicked, and I guess I have to download a plugin or some sort.

Comment 9

6 years ago
That depends on the plugin that is used. QuickTime for instance, will only start playing if it thinks it can guarantee that the audio will not be interrupted. That will depend on the actual download speed that can be measured the first few seconds, but also the actual encoding used and the length of the file. See also the 'enable instant-on' setting in QuickTime's preferences : you cna let is start sooner, but you might encounter a pause later on. I'm not sure why it would react differently under Firefox as under Safari, but it looks to me that Safari was just downloading the file a bit faster.
(Reporter)

Comment 10

6 years ago
Dear Jo,
While I am totally ignorant regarding the technology involved, your last comment about the long time for the music to play on Firefox, compared with the immediate response on Safari, makes me wonder your program is used as in YouTube, waiting for a video, which takes much longer than for music alone. If this were the case, could it be changed? As for making the download more exclusive, we are asking our nephew, who set up the website originally, to help out.
(Reporter)

Comment 11

6 years ago
Hello Rob,

I'm glad to know that you would like to hear my music. Please feel free to listen and download any of my performances. I suggest you use Safari (gabrielbanat.com) and to hear it instantly. #2.of Mozart's Adagio and Rondo might be a good start.  Enjoy. 

See just above for a layman's theory for the difference in response. My thanks to you and your colleagues for your patient help. Best regards from Spain, Gabriel & Diana
You need to log in before you can comment on or make changes to this bug.