Flinging a page that is already scrolling causes the page to stop scrolling momentarily

RESOLVED WORKSFORME

Status

()

Firefox for Android
Toolbar
RESOLVED WORKSFORME
6 years ago
2 years ago

People

(Reporter: cpeterson, Unassigned)

Tracking

({perf, regression})

16 Branch
ARM
Android
perf, regression
Points:
---

Firefox Tracking Flags

(firefox16 affected)

Details

(URL)

(Reporter)

Description

6 years ago
STR:
1. Load a long web page such as timecube.com
2. Quickly fling the page to scroll
3. As the page scrolls down, keep flinging

AR:
The page will sometimes stop scrolling for a moment before handling the new fling event. This doesn't seem like a problem on the ICS stock browser.

This is a subjective bug, but I think it is a regression in Nightly. The momentary stops seem to happen more when scroll down then up a page.
Yes, been meaning to file this; another URL of course is Planet Mozilla.
tracking-fennec: --- → ?
status-firefox16: --- → affected
Keywords: perf, regressionwindow-wanted

Comment 2

6 years ago
I was not able to reproduce this issue.

Build: Firefox 16.0a1 (2012-07-02)
Device: LG Optimus 2X (Android 2.2)
Component: General → Graphics, Panning and Zooming

Updated

6 years ago
Duplicate of this bug: 773274
I can quite easily reproduce this on: http://www.mobilesyrup.com
Waiting for regression range before tracking decision
I cannot reproduce this issue on the latest Nightly, on any of both pages mentioned above. Chris and Aaron, are you able to reproduce this? Was this bug fixed by another patch?

--
Firefox 17.0a1 (2012-07-24)
Device: Galaxy Nexus
OS: Android 4.0.4
This appears as fixed now having tested on mozilla-beta (15.0, beta 1); GN 4.1.1.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
If this was caused by screenshot repainting it may have been fixed by bug 766647. If this is the case it will probably still be happening on current aurora.
(Reporter)

Comment 9

6 years ago
WFM, too.
Keywords: regressionwindow-wanted
(Assignee)

Updated

5 years ago
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.