Closed Bug 769037 Opened 8 years ago Closed 6 years ago

Loading Contacts app is slow

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 871823

People

(Reporter: jrmuizel, Assigned: kgrandon)

References

Details

(Keywords: perf, Whiteboard: [c= p= s=2013.09.06 u=] [sps])

Here's the profile:
http://people.mozilla.com/~bgirard/cleopatra/?report=AMIfv96ZzvY5KslavR9qViykPVb0SYPtJZ6OpTwKT4xCY4VmKM5X45h4w9Mvyj0n0kBbfu53EZR4pc4XugE6hjmaZoQ-oMNMLxkT9hu7kS56rbZY148qVJm46_b2fm8opoRxk-tkqpceoZ2PdIteRuyF9F49pfLCXg

Things of note:
- I've annotated OfflineCache stuff and it does seem to be responsible for the main thread sqlite io.
- We spend a bunch of time loading hyphenation tables. (Do we need to use hyphenation?)
- We spend time loading and sanitizing fonts
- There's 192 ms of waiting time after the end of the animation

I'm working on annotating some more to get a better picture of where more of the time is spent.
(In reply to Jeff Muizelaar [:jrmuizel] from comment #1)
> Here's a profile with better annotations:
> 
> http://people.mozilla.com/~bgirard/cleopatra/?report=AMIfv97E-
> dvDa9oml46f8y2RRrtClHI0ZnkmSTCEuzV-wkiLQ9V-
> OmGJuJlvDm25z_h5v7zIq0GsyejkrmSX4G3Yc0Am88HSgwQ0PUL_1cye8BqIivsHmSYZUZtTkvuf8
> R3Dp6orS3DhvLJPDBI8UEOT8cTg_zvHIg

Where do the annotations appear?
So, ah, the profile suggests that we're doing offline cache disk IO on the main thread.  Please tell me that's not true.
I think offline cache is entirely on the main thread.
All offline cache SQLite IO is sync. FML. Will rewrite today with Thinker.
(In reply to Mike Hommey [:glandium] from comment #2)
> (In reply to Jeff Muizelaar [:jrmuizel] from comment #1)
> > Here's a profile with better annotations:
> > 
> > http://people.mozilla.com/~bgirard/cleopatra/?report=AMIfv97E-
> > dvDa9oml46f8y2RRrtClHI0ZnkmSTCEuzV-wkiLQ9V-
> > OmGJuJlvDm25z_h5v7zIq0GsyejkrmSX4G3Yc0Am88HSgwQ0PUL_1cye8BqIivsHmSYZUZtTkvuf8
> > R3Dp6orS3DhvLJPDBI8UEOT8cTg_zvHIg
> 
> Where do the annotations appear?

A couple of new things are now grouped together. e.g. TextRun construction, hyphenation, css parsing etc.
Depends on: 771298
Whiteboard: [sps]
Component: General → Gaia::Contacts
Should we close this bug now, or make it a meta bug for some more specific bugs (like there still is mozGetAll's lying in the facebook code) ?
Keywords: perf
Blocks: 896835
OS: Linux → Gonk (Firefox OS)
Hardware: x86_64 → ARM
Whiteboard: [sps] → [c= p= s= u=] [sps]
We're actively working on contacts performance in bug #871823. If you have specific actionable items, please open blockers against that bug. I will make a note of things in this bug and investigate them. Thanks!
Assignee: nobody → kgrandon
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 871823
Whiteboard: [c= p= s= u=] [sps] → [c= p= s=2013.09.06 u=] [sps]
You need to log in before you can comment on or make changes to this bug.