"Unable to load address book file ..."

RESOLVED WORKSFORME

Status

Thunderbird
Address Book
--
major
RESOLVED WORKSFORME
6 years ago
4 years ago

People

(Reporter: tsukuda, Unassigned)

Tracking

13 Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [resolved by TB24.x?])

Attachments

(1 attachment)

Comment hidden (empty)

Comment 1

6 years ago
(In reply to tsukuda from comment #0)
You didn't write any details about your bug! Please follow the rules here: https://developer.mozilla.org/en/Bug_writing_guidelines
(Reporter)

Comment 2

6 years ago
Sorry, I was not able to complete last time.

Although I checked the similar reports, I cannot find the solution for loacked adress book files.  When I close Thunderbird 13.0, and re-open it again, the message saying "abook.mab cannot be loaded.  It may be used by other application."  The name of mab file depends on the time.  I have several address book files.  When I load TB right after my PC loaded, all address books can be read without problem.  While I am using TB and other application such as IE or Office programs, etc., the files seem to be locked.  Once they are locked, they cannot be un locked without rebooting the PC.  I do not use LDAP server.  I wonder if Virusscan has something to do with it, since DAT file is renewed everday.
Keywords: common-issue-
Whiteboard: loacked address book files

Comment 3

6 years ago
It can be the antivirus. Or also Thunderbird itself, if you close and reopen it too quickly.
Keywords: common-issue-
Whiteboard: loacked address book files
Can you use Filemon from Mircosoft to figure out what is using the file ?
(Reporter)

Comment 5

6 years ago
I checked Microsoft site and found that Process Monitor (former Filemon) can be run on XP SP2 not SP3.

Comment 6

6 years ago
OK then try Process Explorer http://technet.microsoft.com/en-us/sysinternals/bb896653.
(Reporter)

Comment 7

6 years ago
Thanks.

I tried Process Explorer but except for Thunderbird, no process access Thunderbird files.

Does it matter of timing of opening files?
(In reply to tsukuda from comment #7)
> Thanks.
> 
> I tried Process Explorer but except for Thunderbird, no process access
> Thunderbird files.
> 
> Does it matter of timing of opening files?

Hm, this is a new one for me. Cc'ing Wayne and Roland. Have you folks heard of this one before?

Comment 9

6 years ago
tsukuda, is "abook.mab cannot be loaded" the EXACT text?

only thing comes to mind is where open file handle limit was hit.
(Reporter)

Comment 10

6 years ago
I'm not sure about the exact message in English since mine is the Japanese version.  Seeing from the similar report, the following message should be the one in English:

"Unable to load address book file abook.mab. It may be read-only, or locked by another application. Please try again later."  

The name of file depends on the time but it is always the address book file such as history.mab or impab.mab, etc.

The situation calms down these days.  While the message still pops up randomly after loading, the address book can be read "later".

Comment 11

5 years ago
I see this with the latest Thunderbird on OS X 10.8.3. See attached.
The address book usually works however.

Comment 12

5 years ago
Created attachment 732423 [details]
what I see on every startup.

Comment 13

5 years ago
tsukuda, do you still see this problem?
Flags: needinfo?(tsukuda)
Summary: cannot load the address book files → "Unable to load address book file ..."
Whiteboard: [closeme 2013-11-20]
(Reporter)

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(tsukuda)
Resolution: --- → INVALID

Updated

5 years ago
Whiteboard: [closeme 2013-11-20]
(Reporter)

Comment 14

5 years ago
After the several updates, the problem was resolved.

Thank you for the assistance, anyway.

Comment 15

4 years ago
(In reply to tsukuda from comment #14)
> After the several updates, the problem was resolved.
> 
> Thank you for the assistance, anyway.

Thanks. worksforme is more appropriate.
Resolution: INVALID → WORKSFORME
Whiteboard: [resolved by TB24.x?]
You need to log in before you can comment on or make changes to this bug.