Last Comment Bug 769186 - [devtb] Decide on a key sequence for the developer toolbar
: [devtb] Decide on a key sequence for the developer toolbar
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Developer Tools: Console (show other bugs)
: unspecified
: All All
: P1 normal (vote)
: Firefox 16
Assigned To: Joe Walker [:jwalker] (needinfo me or ping on irc)
:
: Brian Grinstead [:bgrins]
Mentors:
Depends on: 768150
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-28 02:37 PDT by Joe Walker [:jwalker] (needinfo me or ping on irc)
Modified: 2012-07-10 23:45 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
v1 (2.24 KB, patch)
2012-06-28 02:42 PDT, Joe Walker [:jwalker] (needinfo me or ping on irc)
no flags Details | Diff | Splinter Review
v2 (2.14 KB, patch)
2012-07-04 14:55 PDT, Joe Walker [:jwalker] (needinfo me or ping on irc)
dao+bmo: review-
Details | Diff | Splinter Review
v3 (6.73 KB, patch)
2012-07-05 15:46 PDT, Joe Walker [:jwalker] (needinfo me or ping on irc)
ttaubert: review+
Details | Diff | Splinter Review

Description Joe Walker [:jwalker] (needinfo me or ping on irc) 2012-06-28 02:37:35 PDT

    
Comment 1 Joe Walker [:jwalker] (needinfo me or ping on irc) 2012-06-28 02:42:42 PDT
Created attachment 637422 [details] [diff] [review]
v1

This patch reflects what I'd like to do, the correct thing to do is under discussion.

Bug 768150 to pref the toolbar on by default removes the key sequence to avoid a clash with the editor.
Comment 2 Joe Walker [:jwalker] (needinfo me or ping on irc) 2012-07-04 14:55:05 PDT
Created attachment 639186 [details] [diff] [review]
v2

We previously removed the key sequence until we could find one that didn't clash. We found ctrl+shift+/
Comment 3 Tim Taubert [:ttaubert] 2012-07-04 15:00:25 PDT
(In reply to Joe Walker from comment #2)
> We previously removed the key sequence until we could find one that didn't
> clash. We found ctrl+shift+/

Hmm. At least for German users like me and probably other locales this might be a choice as bad as Panorama's next/prev group shortcut. I need to press shift to reach '/' so this effectively overrides the add-on bar toggle, or doesn't work at all and toggles the add-on bar, not sure.
Comment 4 Dão Gottwald [:dao] 2012-07-04 15:17:45 PDT
Comment on attachment 639186 [details] [diff] [review]
v2

"/" happens to be shift+7 with a German keyboard layout and I think shift+: with a French one, making accel+shift+/ inaccessible. We usually keep command keys consistent across locales, and even if we made an exception, I think we could count on localizers getting this wrong. In this case I don't think we should make an exception anyway, as I don't think it's unreasonable for the keyboard layout to divert from what Firefox locales would expect.
Comment 5 Dão Gottwald [:dao] 2012-07-04 15:31:41 PDT
I'm not sure that we really need a keyboard shortcut for the add-on bar; stealing that might be an option. Ironically, it was added for "users who heavily rely on add-ons for certain task modes (e.g. *web development*)" (bug 616015, emphasis mine).
Comment 6 Joe Walker [:jwalker] (needinfo me or ping on irc) 2012-07-04 23:40:43 PDT
https://tbpl.mozilla.org/?tree=Try&rev=d133b4e996e5
Comment 7 Joe Walker [:jwalker] (needinfo me or ping on irc) 2012-07-05 01:37:30 PDT
There aren't good answers to this problem, but I agree that this doesn't work for anyone with a German keyboard.

The developer tools use ctrl+shift/alt+cmd as their modifiers, and there are no free letters without crashing something, I've previously given up on punctuation, for l10n reasons and have done so again, function keys don't work properly on Mac, and numbers are really confusing because we English can't even agree amongst *ourselves* what should be on top of 2. Or 3.

I'm currently trying to work out a way to use ctrl+shift+v (again), and to resolve the conflict with paste-without-formatting in a contenteditable. The UX part of this decision is being done in consultation with shorlander/bdils.
Comment 8 Joe Walker [:jwalker] (needinfo me or ping on irc) 2012-07-05 15:46:49 PDT
Created attachment 639493 [details] [diff] [review]
v3

This update does 2 things:
- It changes the key sequence to shift+F2
- It leaves the menu item as a toggle, but makes the keyboard shortcut a 'focus' shortcut, which takes you to the command line even when the toolbar is already open.
Comment 9 Joe Walker [:jwalker] (needinfo me or ping on irc) 2012-07-05 15:47:43 PDT
https://tbpl.mozilla.org/?tree=Try&rev=5d7593f205b5
Comment 10 Joe Walker [:jwalker] (needinfo me or ping on irc) 2012-07-06 10:27:02 PDT
Bug ping, I'd love to get this into 16 if possible.
Thanks.
Comment 11 Joe Walker [:jwalker] (needinfo me or ping on irc) 2012-07-10 15:09:48 PDT
https://tbpl.mozilla.org/?tree=Fx-Team&rev=74218d787b06
Comment 12 Tim Taubert [:ttaubert] 2012-07-10 23:45:42 PDT
https://hg.mozilla.org/mozilla-central/rev/f942edab3edf

Note You need to log in before you can comment on or make changes to this bug.