crash changing sort column in thread pane

VERIFIED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
--
critical
VERIFIED WORKSFORME
17 years ago
14 years ago

People

(Reporter: hirata masakazu, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

({crash})

Trunk
PowerPC
Mac System 9.x
crash

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
2001041908 mac trunk
Mail/News 3 pane view.
After the first message is selected and displayed, click on the column switches
to change sort key several times.
Result:crash
The stdlog shows various stacktrace probably due to difference in the actual key
used in sort?
(Reporter)

Comment 1

17 years ago
Created attachment 31630 [details]
two stacktraces of the crashes while sorting

Comment 2

17 years ago
I don't see this using various IMAP and POP accounts using  4-19 commercial
trunk build, mac OS 9.0.  Maybe there's some other detail we need to reproduce this.
QA Contact: esther → fenella

Updated

17 years ago
Keywords: crash
(Reporter)

Comment 3

17 years ago
This is very weird.
It seems to require the most recently received message from Bugzilla selected.
Sometimes it crashes when mail box is switched after several attempt at changing
sort order. Sometimes it crashes when an independent mail window is opened after
changing sort order. But I am sure it is crashing repeatedly, and the
stacktraces are varying.
(Reporter)

Comment 4

17 years ago
seems like a dupe of 76914, although details are lacking.

Comment 5

17 years ago
hmmmmm.  Seems similarto bug 76914, but not quite the same.  On HPUX, you only 
have to click the subject or sender tab once, and the browser will core dump 
every time without fail.  Also, if your mail has been set to sort by either 
subject or sender previously (using an older N6 to change the sort and then 
exiting), as soon as it trys to get the messages from the server, the browser 
will core dump.  Since this doesn't happen on linux, I can't see it as being a 
non-platform specific bug.  It would be strange to have a bug that affected only 
Mac and Hpux, but I suppose stranger things have happened.

Comment 6

17 years ago
fenella, can you reproduce this? From the stack trace it looks like you might be
in threaded mode. Is that true?

Comment 7

17 years ago
Scott, using these builds, I cannot reproduce the bug. And I am not the original
reporter, I am not sure if it was in threaded mode.
Linux (2001-04-23-05 trunk)
Win32 (2001-04-23-06 trunk)
Mac (2001-04-23-08 trunk)
(Reporter)

Comment 8

17 years ago
It is still crashing. This involves the default POP account of multiple accounts
in Mail. Another default account crash, I suppose.
(Reporter)

Comment 9

17 years ago
This is still crashing in 042408 mtrunk build.
The crash occurs only in the default POP account among several mail accounts.
Yet another default account crash, I suppose.

Comment 10

17 years ago
I thought we had fixed the one that has Outliner::Invalidate on it.
(Reporter)

Comment 11

17 years ago
I have just crashed sorting and switching mail boxes in the non-default POP
accounts with the same stacktrace.  Therefore, this crash is not limited to the
default POP acocunt. 2001042608 MTrunk
(Reporter)

Comment 12

17 years ago
It is WFM in 2001052804 trunk.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 13

17 years ago
Linux (2001-05-29-05 trunk)
Win32 (2001-05-29-09 trunk)
Mac (2001-05-29-04 trunk)
verified it is fixed.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.