update the l10n milestone documentation to include creation

RESOLVED DUPLICATE of bug 790346

Status

Release Engineering
Release Automation: Other
P1
normal
RESOLVED DUPLICATE of bug 790346
6 years ago
5 years ago

People

(Reporter: bhearsum, Assigned: armenzg)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
Our docs don't talk about how to do it, even though it's a regular thing now.
(Reporter)

Comment 1

6 years ago
Might be good to update the Fennec section as part of this, too: https://wiki.mozilla.org/Release:Release_Automation_on_Mercurial:Preparation#Fennec

I don't think it's all necessary anymore..it talks about maemo-locales

Comment 2

6 years ago
It is necessary; maemo-locales is the leftover name for the file that holds the multilocale locales.
(Assignee)

Updated

6 years ago
Assignee: nobody → armenzg
(Assignee)

Updated

6 years ago
Priority: -- → P2
(Assignee)

Comment 3

6 years ago
I added the info in https://wiki.mozilla.org/Release:Release_Automation_on_Mercurial:Starting_a_Release#Creating_beta_milestones

We *cannot* rename milestones. Only Axel can.
Summary: update the l10n milestone documentation to include creation/renaming → update the l10n milestone documentation to include creation
(Assignee)

Comment 4

6 years ago
Please let me know if the documentation makes sense.
If I hear nothing in one week I will close the bug and hope that we can optimize the documentation as people find issues with it from release to release.

Comment 5

6 years ago
From Axel's email:

There actually isn't anything like "release" milestones, there are just milestones.

The way you create a "release" milestone is that you just go through the regular path, and create milestones for the version that's on beta. (*)

They look release-ish if you give them an empty name, first text field, and a code (second text field) that's having a non-postfixed code, i.e. tb14.

For the fx/fennec ones, the name is ".0.1", which is pasted after the app version name ("Firefox 14"), and the code is fx14.0.1 etc.

That's just manual editing to make them match expectations.


There isn't any documentation about release milestones atm, and it sounded like there wasn't a clear handoff in responsibility?
(Assignee)

Comment 6

6 years ago
What do we want to do here?

Ask Alex/Lukas if the release milestone should be put on Axel's hand and not take responsibility.
(Assignee)

Updated

6 years ago
Priority: P2 → P3
(Assignee)

Updated

6 years ago
Priority: P3 → P1
(Assignee)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 790346
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.