After Nightly update, "install add-on" tabs pop up for every single previously installed add-on.

RESOLVED DUPLICATE of bug 671894

Status

()

--
major
RESOLVED DUPLICATE of bug 671894
6 years ago
6 years ago

People

(Reporter: wenzel, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

6 years ago
Created attachment 637661 [details]
Screenshot

I just updated from yesterday's Nightly to 6/28/2012.

It resulted in one tab for each add-on I had already installed, asking me to confirm that I really want this add-on to be installed.

I further have to *restart* Firefox for every single (not restartless) add-on.

I would expect:
- this dialog not to fire for all my installed add-ons.
- this not to pop up one tab for every add-on (potentially: dozens of tabs)
- this not to require one restart per add-on.

It looks like something exploded, is this working as designed?
(Reporter)

Comment 1

6 years ago
Better yet: After reinstalling all these add-ons, the ones that were previously disabled are now all enabled, so I lost a whole bunch of preferences there and have to disable them one by one again.

If someone disabled an add-on to deal with an incompatibility or a crash, this will not make them a happy camper.
Severity: major → critical
Component: Untriaged → Add-ons Manager
Product: Firefox → Toolkit
QA Contact: untriaged → add-ons.manager
Can you check extensions.log in your profile, and see if theres any mention of NS_ERROR_STORAGE_BUSY? If so, bug 671894 caused this, if not could you attach that log file? Either way, it'd be useful to get a list of your addons (from about:support).

(In reply to Fred Wenzel [:wenzel] from comment #0)
> - this dialog not to fire for all my installed add-ons.

This can happen if we lose the database :( See above, and bug 702506.

> - this not to pop up one tab for every add-on (potentially: dozens of tabs)

Not sure if we have a bug on this already (thought we did have, but I can't find it). I do think we should try to handle that better though - filed bug 769495.

> - this not to require one restart per add-on.

The dialog doesn't make it entirely clear, but you don't have to restart for each non-restartless add-on. Check box, click continue, close tab - add-on will be enabled next time Firefox starts. Filed bug 769494.


> It looks like something exploded

Yes.
(In reply to Fred Wenzel [:wenzel] from comment #1)
> Better yet: After reinstalling all these add-ons, the ones that were
> previously disabled are now all enabled, 

You reinstalled them from AMO? Or enabled them through the about:newaddon tab?

> so I lost a whole bunch of
> preferences there and have to disable them one by one again.

What do you mean "lost preferences"? Lost settings that addons were using?
(Reporter)

Comment 4

6 years ago
Thanks, Blair!

I'll attach the log file. NS_ERROR_STORAGE_BUSY is precisely the error. Does that make this a dupe, then?

(In reply to Blair McBride (:Unfocused) from comment #3)
> (In reply to Fred Wenzel [:wenzel] from comment #1)
> > Better yet: After reinstalling all these add-ons, the ones that were
> > previously disabled are now all enabled, 
> 
> You reinstalled them from AMO? Or enabled them through the about:newaddon
> tab?

The latter. After clicking "Allow this installation" for all those add-ons, they were all enabled.

> > so I lost a whole bunch of
> > preferences there and have to disable them one by one again.
> 
> What do you mean "lost preferences"? Lost settings that addons were using?

No, doesn't look like it, apparently I just lost which add-ons were previously disabled.
(Reporter)

Comment 5

6 years ago
(In reply to Blair McBride (:Unfocused) from comment #2)
> The dialog doesn't make it entirely clear, but you don't have to restart for
> each non-restartless add-on. Check box, click continue, close tab - add-on
> will be enabled next time Firefox starts. Filed bug 769494.

Thanks, that's good. I took that hint after restarting a few times and then I thought, what if I just click and then just restart once?

Do you know if anything would have changed, at all, had I just closed all those tabs? The wording seemed to imply all my add-ons were going to be "blocked" (disabled, presumably) unless I approved them.
(Reporter)

Comment 6

6 years ago
Created attachment 637727 [details]
extensions.log
(Reporter)

Comment 7

6 years ago
Created attachment 637729 [details]
about:support data
(Reporter)

Updated

6 years ago
Severity: critical → major
(In reply to Fred Wenzel [:wenzel] from comment #4)
> I'll attach the log file. NS_ERROR_STORAGE_BUSY is precisely the error. Does
> that make this a dupe, then?

Yep. Add-on Compatibility Reporter used to be one cause for this (I see you have that installed). Its meant to be fixed now, but I think most reports of NS_ERROR_STORAGE_BUSY we get, people have ACR installed - I'll have to look into that to see if its just coincidence or not.

Did you open the Add-ons Manager sometime recently? If so, do you remember seeing a warning at the top about add-on compatibility being disabled? Do you see it now?


> > You reinstalled them from AMO? Or enabled them through the about:newaddon
> > tab?
> 
> The latter. After clicking "Allow this installation" for all those add-ons,
> they were all enabled.

Yea, that's all that checkbox does - checking it means enable the addon, leaving it unchecked means keep it disabled (technically the addon is already "installed" at this point, just not enabled). 

There's a bit of a disconnect there, because dialog is optimized for the expected case where the addon is actually a new install. In the case where the DB is gone, we can't necessarily tell if its new or not - so not sure if we can do anything better there :\

Thinking about it some more, I don't think you should have had a tab open for every addon (I just did a quick test, and it seems to do that). I was sure we were smarter about doing some heuristics to figure out which addons are actually new installs and which aren't - filed bug 769508.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 671894
(In reply to Fred Wenzel [:wenzel] from comment #5)
> Do you know if anything would have changed, at all, had I just closed all
> those tabs? The wording seemed to imply all my add-ons were going to be
> "blocked" (disabled, presumably) unless I approved them.

If you close those tabs without interacting with them, the addons remain installed but disabled (until you enable them through the Add-ons Manager).

If you check "Allow installation", click Continue, then close the tab (without clicking Restart), then that addon would be enabled next time you start Firefox.
(Reporter)

Comment 11

6 years ago
Thanks for answering my questions. A+++ would buy Blair again ;)

Last question: So this was not a bug in tonight's nightly after all, correct?
(In reply to Fred Wenzel [:wenzel] from comment #11)
> Thanks for answering my questions. A+++ would buy Blair again ;)

No problem :)

> Last question: So this was not a bug in tonight's nightly after all, correct?

Correct.
You need to log in before you can comment on or make changes to this bug.