IonMonkey: tryHoistBoundsCheck() should handle JSOP_GE, JSOP_GT.

RESOLVED DUPLICATE of bug 766592

Status

()

RESOLVED DUPLICATE of bug 766592
6 years ago
6 years ago

People

(Reporter: sstangl, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [ion:t])

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 637754 [details]
MIR with failed hoisting.

Earley-Boyer's sc_list() cannot hoist a bounds check because the loop is of the form:

> for (var i = a,length-1; i >= 0; i--)

while currently tryHoistBoundsCheck() only handles loops with < or <= as the comparator.
Relevant MIR attached (instruction 40).
Whiteboard: [ion:t]
This happens since "implement symbolic range analysis"
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 766592
You need to log in before you can comment on or make changes to this bug.