Archiving and IMAP folders that cannot contain messages and subfolders

RESOLVED DUPLICATE of bug 561165

Status

RESOLVED DUPLICATE of bug 561165
7 years ago
3 years ago

People

(Reporter: olaf, Unassigned)

Tracking

13 Branch
x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.1 (KHTML, like Gecko) Chrome/21.0.1145.0 Safari/537.1 SUSE/21.0.1145.0

Steps to reproduce:

I have an IMAP account where folders can only contain either messages or subfolders.
Furthermore, I am using two mail identities with this account.
For the account, I set the archiving options to "Monthly archives", so that messages are archived to e.g. Archives/2012/2012-06.
I wasn't aware that each mail identity has its own set of archiving options. For my second identity, the options were set to "Yearly archives".

What I did was to try to archive a message for the second mail id.


Actual results:

Instead of the message being archived or a telling error message, I got the error message: "The current operation on 'Test' did not succeed. The mail server for account somebody@somewhere.com responded: Mailbox isn't selectable: Archives/2012."


Expected results:

At the least, the message could have been more telling, e.g. 

"Trying to archiving a message for altmail@somewhere.com from 'Test' to folder 'Archives/2012' on mail server for account somebody@somewhere.com which already contains subfolders but cannot contain both messages and subfolders."

This message contains the mail id for that the message is archived, and also explains why the message could not be copied. To my understanding, TB should have all information required for this message: it knows for what mail id it it working, it knows that the folder is on a server that doesn't support both messages and subfolders in a folder, and that the folder already contains subfolders.

Of course it would be even better if it wouldn't be possible to choose different archiving options for different mail ids on such a server in the first place, or at least to give a warning in that case.

Updated

6 years ago
Component: General → Untriaged
olaf,
are you still seeing this?
What imap server are you using?
duplicate of bug 561165 or bug 485002?
Flags: needinfo?(olaf)
(Reporter)

Comment 2

3 years ago
Sorry, I do not have access to the system anymore, and also I'm not really working with Thunderbird anymore. The IMAP server was dovecot, though.
Flags: needinfo?(olaf)
Thanks for the update.
Might be bug 561165
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 561165
You need to log in before you can comment on or make changes to this bug.