on startup, scrollbar in thread pane is somewhere in the middle

RESOLVED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
RESOLVED WORKSFORME
17 years ago
14 years ago

People

(Reporter: sairuh (rarely reading bugmail), Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
see this on linux and mac [2001.04.20.1x], and nbaca sees this on win32. when i
first open the mailnews 3pane window [both regular and alternate layouts], the
scrollbar in the thread pane is always somewhere in the middle --never at the
top or the bottom of the thread pane. seems odd, since there are no thread items
selected [in focus] upon startup.
(Reporter)

Comment 1

17 years ago
it'd make sense for the scrollbar to be either at the very top or bottom of the
thread pane upon startup. jglick, what's your UI recommendation here?
Keywords: nsCatFood

Comment 2

17 years ago
Most users sort by date.  So what about: If the user is sorting desending order, 
the scrollbar defaults to the top (showing the messages at the top)(for Date, 
this is the newest messages).  If the user is sorting by assending order, the 
scrollbar defaults to the bottom (showing the messages at the bottom)(for Date, 
this is the newest messages).  If sorting by other columns we could following 
the assending/desending logic too?

Comment 3

17 years ago
Sairuh, it might be in the middle for you, because you have unread emails there?

By default, our outliner widget scrolls to the first unread message at startup,
so this is not a bug but rather a feature.

Comment 4

17 years ago
When you open a drawer in your desk, stuff is (usually) in exactly the same 
place as it was last time you closed the drawer. This is good, because it helps 
you remember where things are.

For the same reason, when you open the three-pane window in Mozilla, I think 
the scrollbar should be in exactly the same position as it was when the window 
was last closed. This is how the Mac OS Finder works, for example.

Comment 5

17 years ago
See bug 38222.  Should scroll to, but not select the first new message.
(Reporter)

Comment 6

17 years ago
hwaara: nope, this happens to me even when [for example] my Inbox contains no
new or unread messages.

mpt: i don't think the folder is remembering the last place i was looking at
either. for example, let's say the last message i was reading [eg, in the Inbox]
was the last [bottom-most] message, with the scrollbar at the bottom of the
thread pane. i quit the app and reopen mail --and initially the scrollbar is
still somewhere in the middle [not at the bottom] of the thread pane.

Comment 7

17 years ago
The original bug was about scrollbar (i assume thumb) was somewhere in the middle).

Testing with a current CVS, Linux:
-when i start mailnews and there are no unread mail: scrollbar thumb is at top.
-when i start mailnews and there IS unread mail, it is scrolled to

This is how I would expect it to work, and how I like it. WFM.

Comment 8

15 years ago
This worksforme with 2004020909 windows Seamonkey build. 
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.