Last Comment Bug 769653 - nsDOMDataTransfer::FillInExternalDragData is missing an Init call for the new transferable
: nsDOMDataTransfer::FillInExternalDragData is missing an Init call for the new...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM: Events (show other bugs)
: Trunk
: x86 Mac OS X
: -- normal (vote)
: mozilla16
Assigned To: :Ehsan Akhgari (busy, don't ask for review please)
:
Mentors:
: 769961 (view as bug list)
Depends on:
Blocks: 722872
  Show dependency treegraph
 
Reported: 2012-06-29 07:13 PDT by Josh Matthews [:jdm]
Modified: 2012-06-30 15:52 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (v1) (1.70 KB, patch)
2012-06-29 08:42 PDT, :Ehsan Akhgari (busy, don't ask for review please)
bzbarsky: review+
Details | Diff | Review

Description Josh Matthews [:jdm] 2012-06-29 07:13:16 PDT

    
Comment 1 :Ehsan Akhgari (busy, don't ask for review please) 2012-06-29 08:34:02 PDT
Wow, how did you find this?!
Comment 2 Kyle Huey [:khuey] (khuey@mozilla.com) 2012-06-29 08:34:51 PDT
Drag anything into the browser on Windows.
Comment 3 :Ehsan Akhgari (busy, don't ask for review please) 2012-06-29 08:40:57 PDT
Hmm, this code is not exercised by any of our tests, that's for sure.
Comment 4 Kyle Huey [:khuey] (khuey@mozilla.com) 2012-06-29 08:42:31 PDT
Right.
Comment 5 :Ehsan Akhgari (busy, don't ask for review please) 2012-06-29 08:42:33 PDT
Created attachment 637917 [details] [diff] [review]
Patch (v1)
Comment 6 Boris Zbarsky [:bz] (Out June 25-July 6) 2012-06-29 09:10:43 PDT
Comment on attachment 637917 [details] [diff] [review]
Patch (v1)

r=me
Comment 7 :Ehsan Akhgari (busy, don't ask for review please) 2012-06-29 09:22:52 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/0e9d5367addb
Comment 8 Ryan VanderMeulen [:RyanVM] 2012-06-30 12:45:00 PDT
https://hg.mozilla.org/mozilla-central/rev/0e9d5367addb
Comment 9 Daniel Holbert [:dholbert] (largely AFK until June 28) 2012-06-30 15:52:51 PDT
*** Bug 769961 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.