Last Comment Bug 769822 - Cannot see availability / free/busy status in Thunderbird
: Cannot see availability / free/busy status in Thunderbird
Status: RESOLVED FIXED
:
Product: Calendar
Classification: Client Software
Component: Provider: CalDAV (show other bugs)
: Lightning 1.6
: All Other
: -- minor (vote)
: 1.9
Assigned To: Philipp Kewisch [:Fallen]
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-29 14:47 PDT by Joel Braddock :jbraddock
Modified: 2012-08-09 11:35 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Fix - v1 (4.93 KB, patch)
2012-08-03 06:24 PDT, Philipp Kewisch [:Fallen]
no flags Details | Diff | Splinter Review
Fix - v2 (4.92 KB, patch)
2012-08-04 00:53 PDT, Philipp Kewisch [:Fallen]
mohit.kanwal: review+
Details | Diff | Splinter Review

Description Joel Braddock :jbraddock 2012-06-29 14:47:52 PDT
Paul Jarratt: Cannot see availability in Thunderbird

Can add people, but cannot see if they are free/busy.
Comment 1 Joel Braddock :jbraddock 2012-06-29 15:24:08 PDT
Guillermo - Can you let me know if it is possible in Thunderbird (with Lightening) to see availability when you add a user to a meeting? Thanks!
Comment 2 Joel Braddock :jbraddock 2012-07-03 15:53:46 PDT
Paul - I have asked around to a couple of my teammates and it looks like Thunderbird is not able to view a users availability when inviting them to a meeting. Sorry about this. If I hear of a way in the future, I will update the bug and give you instructions.

Thanks - Joel
Comment 3 Paul Jarratt 2012-07-03 16:25:25 PDT
OK thanks Joel.
Comment 4 Guillermo Huerta [:guillermo] 2012-07-11 16:02:28 PDT
Paul this is working for me.  But it seems to brake with some lightning updates.  What version of thunderbird and lightning are you on?
Comment 5 Paul Jarratt 2012-07-12 09:20:13 PDT
13.0.1 - Thunderbird
1.5.2 - Lightning
Comment 6 Guillermo Huerta [:guillermo] 2012-07-16 12:47:40 PDT
Yeah, it is working for me with those versions.  Do you mind creating a fresh profile and testing with it?
Comment 7 Paul Jarratt 2012-07-16 12:53:06 PDT
Does that mean I just have to delete and download it again? Not sure how to create a new profile? Will I loose saved appointments?
Comment 8 Joel Braddock :jbraddock 2012-07-16 15:41:00 PDT
Paul, I can help you out since you are in the SF office. When would you have time to test?
Comment 9 Joel Braddock :jbraddock 2012-07-19 11:51:12 PDT
Paul - What is the update on this?
Comment 10 Paul Jarratt 2012-07-20 11:21:55 PDT
I didn't have time to track Joel down yesterday. Still not working. Will try reaching out to him today.
Comment 11 Joel Braddock :jbraddock 2012-07-20 16:49:31 PDT
Paul - Patrick will be covering for me the next two weeks in SFO, please reach out to him for assistance.
Comment 12 Patrick Dang [:pdang] 2012-07-23 14:14:38 PDT
Hello Paul, do you have time to troubleshoot this issue today?
Comment 13 Paul Jarratt 2012-07-23 15:42:54 PDT
Not really, could we do it tomorrow?
Comment 14 Patrick Dang [:pdang] 2012-07-23 16:16:39 PDT
Sure, I'll follow up with you tomorrow.
Comment 15 Patrick Dang [:pdang] 2012-07-24 11:34:50 PDT
e-mailed user to follow up
Comment 16 Patrick Dang [:pdang] 2012-07-24 15:17:29 PDT
Paul, where do you sit?
Comment 17 Patrick Dang [:pdang] 2012-07-24 16:27:47 PDT
followed up with user. confirmed that availability cannot be viewed on my computer either.
Comment 18 Paul Jarratt 2012-08-02 14:47:38 PDT
Hi 
Just wondered if there was an update on this?
Thanks

Paul
Comment 19 Philipp Kewisch [:Fallen] 2012-08-03 06:24:23 PDT
Created attachment 648683 [details] [diff] [review]
Fix - v1

The problem is that on calendars that support calendar-schedule but not calendar-auto-schedule the freebusy provider is not correctly re-registered after a restart when the calendar properties are taken from the cache. The original code checks specifically for the dav header when adding the FB provider, while the cached code just checks hasSchedule, which is always false with calendar.caldav.sched.enabled = false**.

This patch takes care in two parts: 

* Add a new property that checks if the freebusy provider has been added, which is only set true and cached when the server supports calendar-schedule.

* Run the check for server info once per session, given we are in an online state. if we start out offline, the server info is taken from the cache. When we go online then the refresh will do the check for server info again, overwriting the previous values. 


** NOTE: calendar.caldav.sched.enabled = false is the default, and its probably broken so don't turn it on to try to workaround!
Comment 20 Philipp Kewisch [:Fallen] 2012-08-04 00:53:36 PDT
Created attachment 648967 [details] [diff] [review]
Fix - v2
Comment 21 Mohit Kanwal [:redDragon] 2012-08-09 10:47:25 PDT
Comment on attachment 648967 [details] [diff] [review]
Fix - v2

Review of attachment 648967 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good to me.
Comment 22 Philipp Kewisch [:Fallen] 2012-08-09 11:35:51 PDT
Pushed to comm-central changeset 4f96a894be5e

Note You need to log in before you can comment on or make changes to this bug.