Crash [@ ns_if_addref<nsIControllers*> ]

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
6 years ago
5 years ago

People

(Reporter: chriechers, Unassigned)

Tracking

({crash})

13 Branch
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:14.0) Gecko/20100101 Firefox/14.0
Build ID: 20120624012213



Actual results:

An infrequent Thunderbird crash. TB13.0.1 on OpenSuSE Linux 11.4.
ID: bp-63520609-8f6d-4ead-895e-2c0212120627
Crash Report  [@ ns_if_addref<nsIControllers*> ]
(Reporter)

Updated

6 years ago
Crash Signature: [@ ns_if_addref<nsIControllers*> ]
Keywords: crash
0 	libxul.so 	ns_if_addref<nsIControllers*> 	nsISupportsUtils.h:94
1 	libxul.so 	nsXULElement::GetControllers 	content/xul/content/src/nsXULElement.cpp:1854
2 	libxul.so 	nsWindowRoot::GetControllers 	dom/base/nsWindowRoot.cpp:227
3 	libxul.so 	nsWindowRoot::GetControllerForCommand 	dom/base/nsWindowRoot.cpp:261
4 	libxul.so 	nsXULCommandDispatcher::GetControllerForCommand 	content/xul/document/src/nsXULCommandDispatcher.cpp:504
5 	libxul.so 	libxul.so@0xfaa5ef 	
6 	libxul.so 	XPCWrappedNative::CallMethod 	js/xpconnect/src/XPCWrappedNative.cpp:3026
7 	libxul.so 	XPC_WN_CallMethod 	js/xpconnect/src/XPCWrappedNativeJSOps.cpp:1539
8 		@0xa559ee09 	
9 	libxul.so 	libxul.so@0x1787eef 	
10 	libxul.so 	js::mjit::EnterMethodJIT 	js/src/methodjit/MethodJIT.cpp:1052
11 	libxul.so 	js::mjit::JaegerShot 	js/src/methodjit/MethodJIT.cpp:1111
12 	libxul.so 	js::Interpret 	js/src/jsinterp.cpp:2756
13 	libxul.so 	js::InvokeKernel 	js/src/jsinterp.cpp:529
14 	libxul.so 	js::Invoke 	js/src/jsinterp.h:172
15 	libxul.so 	JS_CallFunctionValue 	js/src/jsapi.cpp:5432
16 	libxul.so 	nsJSContext::CallEventHandler 	dom/base/nsJSEnvironment.cpp:1880
17 	libxul.so 	nsJSEventListener::HandleEvent 	dom/src/events/nsJSEventListener.cpp:239
18 	libxul.so 	nsEventListenerManager::HandleEventSubType 	content/events/src/nsEventListenerManager.cpp:742
19 	libxul.so 	nsEventListenerManager::HandleEventInternal 	content/events/src/nsEventListenerManager.cpp:800
20 	libxul.so 	nsEventTargetChainItem::HandleEvent 	content/events/src/nsEventDispatcher.cpp:216
21 	libxul.so 	nsEventTargetChainItem::HandleEventTargetChain 	content/events/src/nsEventDispatcher.cpp:348
22 	libxul.so 	nsEventDispatcher::Dispatch 	content/events/src/nsEventDispatcher.cpp:682
23 	libxul.so 	nsXULCommandDispatcher::UpdateCommands 	content/xul/document/src/nsXULCommandDispatcher.cpp:455
24 	libxul.so 	libxul.so@0xfaa5ef 	
25 	libxul.so 	XPCWrappedNative::CallMethod 	js/xpconnect/src/XPCWrappedNative.cpp:3026
26 	libxul.so 	XPC_WN_CallMethod 	js/xpconnect/src/XPCWrappedNativeJSOps.cpp:1539
27 	libxul.so 	js::InvokeKernel 	js/src/jscntxtinlines.h:314
28 	libxul.so 	js::Interpret 	js/src/jsinterp.cpp:2711
29 	libxul.so 	js::InvokeKernel 	js/src/jsinterp.cpp:529
30 	libxul.so 	js::Invoke 	js/src/jsinterp.h:172
31 	libxul.so 	JS_CallFunctionValue 	js/src/jsapi.cpp:5432
32 	libxul.so 	nsJSContext::CallEventHandler 	dom/base/nsJSEnvironment.cpp:1880
33 	libxul.so 	nsJSEventListener::HandleEvent 	dom/src/events/nsJSEventListener.cpp:239
34 	libxul.so 	nsEventListenerManager::HandleEventSubType 	content/events/src/nsEventListenerManager.cpp:742
35 	libxul.so 	nsEventListenerManager::HandleEventInternal 	content/events/src/nsEventListenerManager.cpp:800
36 	libxul.so 	nsEventTargetChainItem::HandleEvent 	content/events/src/nsEventDispatcher.cpp:216
37 	libxul.so 	nsEventTargetChainItem::HandleEventTargetChain 	content/events/src/nsEventDispatcher.cpp:348
38 	libxul.so 	nsEventDispatcher::Dispatch 	content/events/src/nsEventDispatcher.cpp:682
39 	libxul.so 	nsXULCommandDispatcher::UpdateCommands 	content/xul/document/src/nsXULCommandDispatcher.cpp:455
40 	libxul.so 	CommandDispatcher::Run 	dom/base/nsGlobalWindow.cpp:7289
41 	libxul.so 	nsContentUtils::AddScriptRunner 	content/base/src/nsContentUtils.cpp:4822
42 	libxul.so 	nsGlobalWindow::UpdateCommands 	dom/base/nsGlobalWindow.cpp:7312
43 	libxul.so 	nsFocusManager::Focus 	dom/base/nsFocusManager.cpp:1822
44 	libxul.so 	nsFocusManager::SetFocusInner 	dom/base/nsFocusManager.cpp:1275
45 	libxul.so 	nsFocusManager::SetFocus 	dom/base/nsFocusManager.cpp:467
46 	libxul.so 	nsEventStateManager::PostHandleEvent 	content/events/src/nsEventStateManager.cpp:3109
47 	libxul.so 	PresShell::HandleEventInternal 	layout/base/nsPresShell.cpp:6588
48 	libxul.so 	PresShell::HandlePositionedEvent 	layout/base/nsPresShell.cpp:6230
49 	libxul.so 	PresShell::HandleEvent 	layout/base/nsPresShell.cpp:6060
50 	libxul.so 	nsViewManager::DispatchEvent 	view/src/nsViewManager.cpp:908
51 	libxul.so 	HandleEvent 	view/src/nsView.cpp:158
52 	libxul.so 	nsWindow::DispatchEvent 	widget/gtk2/nsWindow.cpp:524
53 	libxul.so 	nsWindow::OnButtonPressEvent 	widget/gtk2/nsWindow.cpp:2774
54 	libxul.so 	button_press_event_cb 	widget/gtk2/nsWindow.cpp:5565
55 	libgtk-x11-2.0.so.0.2200.1 	libgtk-x11-2.0.so.0.2200.1@0x13dd83 	
56 	libgobject-2.0.so.0.2800.0 	libgobject-2.0.so.0.2800.0@0xc873 	
57 	libxul.so 	nsWindow::OnButtonPressEvent 	widget/gtk2/nsWindow.cpp:2785
58 	libpthread-2.11.3.so 	libpthread-2.11.3.so@0x9448 	
59 	libgobject-2.0.so.0.2800.0 	libgobject-2.0.so.0.2800.0@0x4eff3 	
60 	libgtk-x11-2.0.so.0.2200.1 	libgtk-x11-2.0.so.0.2200.1@0x13dcef 	
61 	libpthread-2.11.3.so 	libpthread-2.11.3.so@0x7f9e 	
62 	libpthread-2.11.3.so 	libpthread-2.11.3.so@0x9448 	
63 	libgobject-2.0.so.0.2800.0 	libgobject-2.0.so.0.2800.0@0x4eff3 	
64 	libpthread-2.11.3.so 	libpthread-2.11.3.so@0x951f 	
65 	libgobject-2.0.so.0.2800.0 	libgobject-2.0.so.0.2800.0@0x1f28b 	
66 	libgobject-2.0.so.0.2800.0 	libgobject-2.0.so.0.2800.0@0x4eff3 	
67 	libgobject-2.0.so.0.2800.0 	libgobject-2.0.so.0.2800.0@0x1cd5f 	
68 	libgobject-2.0.so.0.2800.0 	libgobject-2.0.so.0.2800.0@0x3fcc0 	
69 	libgobject-2.0.so.0.2800.0 	libgobject-2.0.so.0.2800.0@0x3bf03 	
70 	libgobject-2.0.so.0.2800.0 	libgobject-2.0.so.0.2800.0@0x4f453 	
71 	libgobject-2.0.so.0.2800.0 	libgobject-2.0.so.0.2800.0@0xe800 	
72 	libgobject-2.0.so.0.2800.0 	libgobject-2.0.so.0.2800.0@0x40569 	
73 	libgobject-2.0.so.0.2800.0 	libgobject-2.0.so.0.2800.0@0x4eff3 	
74 	libpthread-2.11.3.so 	libpthread-2.11.3.so@0x7f9e 	
75 	libgobject-2.0.so.0.2800.0 	libgobject-2.0.so.0.2800.0@0x1e46a 	
76 	libgobject-2.0.so.0.2800.0 	libgobject-2.0.so.0.2800.0@0x4eff3 	
77 	libgobject-2.0.so.0.2800.0 	libgobject-2.0.so.0.2800.0@0x28219 	
78 	thunderbird 	malloc_mutex_lock 	memory/jemalloc/jemalloc.c:1604
79 		@0x0 	
80 	libgobject-2.0.so.0.2800.0 	libgobject-2.0.so.0.2800.0@0x4f453 	
81 	thunderbird 	malloc_mutex_unlock 	memory/jemalloc/jemalloc.c:1613
82 		@0xbfb5096b
Severity: normal → critical
Status: UNCONFIRMED → NEW
Component: General → XUL
Ever confirmed: true
Product: Thunderbird → Core
QA Contact: general → xptoolkit.widgets
Version: 13 → 13 Branch
(Reporter)

Comment 3

5 years ago
Yes, I haven't seen this one since quite a while.
Flags: needinfo?(chriechers)
(Reporter)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.