Firefox 13.0.1. consumes huge amounts of CPU (due to leap second ?)

RESOLVED INVALID

Status

()

Core
General
RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: Alain Knaff, Unassigned)

Tracking

13 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:13.0) Gecko/20100101 Firefox/13.0.1
Build ID: 20120615040358

Steps to reproduce:

Start up Firefox, even in safe-mode


Actual results:

Already immediately from the start, CPU consumption jumped at over 50%. If I actually do stuff, it goes over 100%


Expected results:

An idle Firefox, with no tabs should consume next to nothing.
And even with Facebook open, it definitely should consume less than 5% on this 2600 Mhz AMD CPU.
Opera can do it, why not firefox?
(Reporter)

Comment 1

6 years ago
Oddly enough, after restarting my whole system, firefox is fast again.

Just restarting only firefox was not enough to achieve this.

Weird.

Comment 2

6 years ago
I got the same behavior. Only reboot helped. Matti thinks related to the kernel leap second issue, which would explain the need to reboot.
Status: UNCONFIRMED → NEW
Ever confirmed: true
We had a leap second from June 30 to July 1
ftp://hpiers.obspm.fr/iers/bul/bulc/bulletinc.43

That the lap second could be responsible for this is really just a guess from my side.
The guess is based on articles like this http://pedroalves-bi.blogspot.de/2012/07/java-leap-second-bug-how-to-fix-your.html and 2 unique reports from Firefox linux users.

Reproducing and fixing this could be impossible due to rare occurrence of leap seconds.
Component: Untriaged → General
Product: Firefox → Core
QA Contact: untriaged → general
Summary: Firefox 13.0.1. consumes huge amounts of CPU → Firefox 13.0.1. consumes huge amounts of CPU (due to leap second ?)
This seems to be a bug in the kernel:
http://thread.gmane.org/gmane.linux.kernel/1321255/

Comment 5

6 years ago
(In reply to Matthias Versen (Matti) from comment #4)
> This seems to be a bug in the kernel:
> http://thread.gmane.org/gmane.linux.kernel/1321255/

so not solvable by Firefox?
Keywords: perf
Should be solved by bug fixes ion the kernel. Mozilla wasn't the only software affected by this bug
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Keywords: perf
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.