Intermittent TEST-UNEXPECTED-FAIL | layout/reftests/backgrounds/* | image comparison (==) off by one

RESOLVED WORKSFORME

Status

()

Core
Layout
RESOLVED WORKSFORME
6 years ago
3 years ago

People

(Reporter: RyanVM, Unassigned)

Tracking

({intermittent-failure})

Trunk
All
Mac OS X
intermittent-failure
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
I have no idea how bug 758034 managed to cause it, but since it landed, OSX opt builds are seeing a ~20% failure rate in the various background reftests. The common thread amongst all them is an off by one error on the left border of the test. I've spent all day running reftests and confirmed bug 758034 to be the cause. Backing out on Try also confirmed it:
https://tbpl.mozilla.org/?tree=Try&rev=ce7a86f38dee

Bill, we decided to leave your patches in for now, but please look in to this ASAP as it is a pretty frequent source of random orange on OSX.

Here's one example log (and more to be linked shortly).
https://tbpl.mozilla.org/php/getParsedLog.php?id=13149922&tree=Mozilla-Inbound&full=1

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

5 years ago
Keywords: intermittent-failure
(Assignee)

Updated

5 years ago
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.