Last Comment Bug 770116 - Test failure 'The pane did not load in time: paneTabs ' when switching panes in preferences window
: Test failure 'The pane did not load in time: paneTabs ' when switching panes ...
Status: RESOLVED FIXED
[mozmill-test-failure]
:
Product: Mozilla QA
Classification: Other
Component: Mozmill Tests (show other bugs)
: unspecified
: All Mac OS X
: -- normal (vote)
: ---
Assigned To: Remus Pop (:RemusPop)
:
Mentors:
Depends on:
Blocks: 757340
  Show dependency treegraph
 
Reported: 2012-07-02 03:48 PDT by Henrik Skupin (:whimboo)
Modified: 2012-07-03 08:31 PDT (History)
2 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---
fixed
fixed
fixed
fixed
fixed


Attachments
patch v1 (aurora) (1.44 KB, patch)
2012-07-03 06:24 PDT, Remus Pop (:RemusPop)
hskupin: review+
Details | Diff | Review

Description Henrik Skupin (:whimboo) 2012-07-02 03:48:17 PDT
With the fix on bug 757340 we have introduced a new regression which is intermittent. In some cases tests fail to switch to the target pane due to a timeout in our test. We probably should increase it. How long was the waiting time before? Remus, can you please take that?

http://mozmill-ci.blargon7.com/#/l10n/report/23e194f1171aa4baf774928b2624c069
Comment 1 Remus Pop (:RemusPop) 2012-07-02 04:11:31 PDT
We were using the default timeout (5s). So the waiting time is the same.
Comment 2 Remus Pop (:RemusPop) 2012-07-02 08:08:54 PDT
The problem is that with the no animation pref of the pref pane, nodeToProcess.style.opacity == 1 will always be false.
Comment 3 Henrik Skupin (:whimboo) 2012-07-02 13:01:27 PDT
Why is that a problem? We do not rely on this CSS style in our test. Why should it then affect the waitFor() call?
Comment 4 Remus Pop (:RemusPop) 2012-07-02 23:59:11 PDT
That line is the one that makes the waitFor pass on Mac when we the animation is on.
Comment 5 Henrik Skupin (:whimboo) 2012-07-03 00:37:09 PDT
We do not have the animation enabled! We pref it off before changing the panes. What we are waiting for is the target pane to be selected. There is no transition related code in here:

http://hg.mozilla.org/qa/mozmill-tests/file/32421e34b8d8/lib/prefs.js#l90

Please try if you can reproduce locally.
Comment 6 Remus Pop (:RemusPop) 2012-07-03 01:02:43 PDT
I was talking about this waitFor:
http://hg.mozilla.org/qa/mozmill-tests/file/32421e34b8d8/lib/dom-utils.js#l345

Yes, I can reproduce it locally.
Comment 7 Henrik Skupin (:whimboo) 2012-07-03 01:21:11 PDT
Oh wow. Yes, those to lines have to be removed than.
Comment 8 Remus Pop (:RemusPop) 2012-07-03 01:51:28 PDT
What 2 lines? Please check the whole condtion.
Comment 9 Henrik Skupin (:whimboo) 2012-07-03 02:33:57 PDT
(In reply to Remus Pop (:RemusPop) from comment #8)
> What 2 lines? Please check the whole condtion.

Those two lines you was talking about in comment 2. If you have problems please lets discuss this on IRC. This process here slows us down.
Comment 10 Remus Pop (:RemusPop) 2012-07-03 06:24:17 PDT
Created attachment 638686 [details] [diff] [review]
patch v1 (aurora)

The style is no longer affected if we don't have animation (which is disabled in the setter of paneId BTW) so I removed it.
Comment 11 Henrik Skupin (:whimboo) 2012-07-03 07:41:47 PDT
Comment on attachment 638686 [details] [diff] [review]
patch v1 (aurora)

That works. Thanks for the patch!
Comment 12 Henrik Skupin (:whimboo) 2012-07-03 07:46:39 PDT
Given that we do not have any tests running on default only which exercise this code path, I pushed it to default and aurora:

http://hg.mozilla.org/qa/mozmill-tests/rev/a3b6cf6264c5 (default)
http://hg.mozilla.org/qa/mozmill-tests/rev/40b3a0afa3ac (aurora)

If that works I will land on the other branches soon.

Note You need to log in before you can comment on or make changes to this bug.