If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

The createPattern() method of the canvas.getContext("2d") object fail for the repeat-x and repeat-y values in the repeat parameter

RESOLVED DUPLICATE of bug 468358

Status

()

Core
Canvas: 2D
RESOLVED DUPLICATE of bug 468358
5 years ago
4 years ago

People

(Reporter: RANCHIN, Unassigned)

Tracking

13 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

3.36 KB, application/octet-stream
Details
(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:13.0) Gecko/20100101 Firefox/13.0.1
Build ID: 20120614114901

Steps to reproduce:

The createPattern(image,repeat) method, of the canvas.getContext("2d") object, fill the background with the image.



Actual results:

repeat - repeat the image horizontaly and verticaly = OK
repeat-x - repeat the image horizontaly and verticaly = Fail
repeat-y - repeat the image horizontaly and verticaly = Fail
no-repeat - show one image = OK


Expected results:

repeat - repeat the image horizontaly and verticaly
repeat-x - repeat the image horizontaly
repeat-y - repeat the image verticaly
no-repeat - show one image

Comment 1

5 years ago
Could you provide a small testcase?
(Reporter)

Comment 2

5 years ago
Created attachment 646658 [details]
A HTML5 test file

This HTML5 test file use the createPattern() method whis different values of the repeat parameter. Use it whis Firefox. Then use it whis Opera or Google Chrome and see the difference.

Updated

4 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Component: Untriaged → Canvas: 2D
Product: Firefox → Core
Resolution: --- → DUPLICATE
Duplicate of bug: 468358
You need to log in before you can comment on or make changes to this bug.