Last Comment Bug 770139 - Status icon in message header and chat toolbar are different
: Status icon in message header and chat toolbar are different
Status: RESOLVED FIXED
:
Product: Thunderbird
Classification: Client Software
Component: Theme (show other bugs)
: Trunk
: x86_64 Linux
: -- normal (vote)
: Thunderbird 17.0
Assigned To: Andreas Nilsson (:andreasn)
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-02 05:29 PDT by Andreas Nilsson (:andreasn)
Modified: 2012-08-13 18:21 PDT (History)
4 users (show)
ryanvm: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
patch to use the icons in themes instead (2.96 KB, patch)
2012-07-02 06:28 PDT, Andreas Nilsson (:andreasn)
mconley: ui‑review+
Details | Diff | Splinter Review
Screenshot (Linux) (29.01 KB, image/png)
2012-07-09 08:10 PDT, Andreas Nilsson (:andreasn)
no flags Details
patch (v2) (2.90 KB, patch)
2012-07-11 03:12 PDT, Andreas Nilsson (:andreasn)
florian: review+
bugs: ui‑review+
Details | Diff | Splinter Review

Description Andreas Nilsson (:andreasn) 2012-07-02 05:29:36 PDT
They message header status icon and the toolbar icon is styled differently.
Comment 1 Andreas Nilsson (:andreasn) 2012-07-02 06:28:10 PDT
Created attachment 638333 [details] [diff] [review]
patch to use the icons in themes instead

This uses the platform specific presence icons in themes instead.
Comment 2 Andreas Nilsson (:andreasn) 2012-07-02 06:57:14 PDT
Comment on attachment 638333 [details] [diff] [review]
patch to use the icons in themes instead

Let me know if you need screenshots.
Comment 3 Mike Conley (:mconley) 2012-07-05 11:10:55 PDT
(In reply to Andreas Nilsson (:andreasn) from comment #2)
> Comment on attachment 638333 [details] [diff] [review]
> patch to use the icons in themes instead
> 
> Let me know if you need screenshots.

Yes please on the screenshots. :)
Comment 4 Andreas Nilsson (:andreasn) 2012-07-09 08:10:02 PDT
Created attachment 640223 [details]
Screenshot (Linux)
Comment 5 Mike Conley (:mconley) 2012-07-09 09:37:23 PDT
Comment on attachment 638333 [details] [diff] [review]
patch to use the icons in themes instead

Applied patch looks good to me.

ui-r=me.
Comment 6 Florian Quèze [:florian] [:flo] 2012-07-10 08:42:14 PDT
(In reply to Andreas Nilsson (:andreasn) from comment #4)
> Created attachment 640223 [details]
> Screenshot (Linux)

Andreas, is there any reason why on the "new" screenshot the icon used is the 'idle' one (the orange icon with a clock) but on the "old" screenshot it was the 'unavailable' icon (red dot)?
Comment 7 Andreas Nilsson (:andreasn) 2012-07-10 08:43:51 PDT
It was because Hanne went idle during my compile :)
Comment 8 Florian Quèze [:florian] [:flo] 2012-07-10 10:39:09 PDT
(In reply to Andreas Nilsson (:andreasn) from comment #7)
> It was because Hanne went idle during my compile :)

But the code uses only two icons (it used to be available.png and away.png before your changes), 'idle' isn't handled by that code.
Comment 9 Andreas Nilsson (:andreasn) 2012-07-10 10:42:37 PDT
(In reply to Florian Quèze from comment #8)
> (In reply to Andreas Nilsson (:andreasn) from comment #7)
> > It was because Hanne went idle during my compile :)
> 
> But the code uses only two icons (it used to be available.png and away.png
> before your changes), 'idle' isn't handled by that code.

Crap, I think you're right. I mixed those up. I'll fix the regressions and post a new patch.
Comment 10 Andreas Nilsson (:andreasn) 2012-07-11 03:12:06 PDT
Created attachment 640992 [details] [diff] [review]
patch (v2)

Carrying over ui-r+ and asking for new review.
Comment 11 Ryan VanderMeulen [:RyanVM] 2012-08-13 18:21:56 PDT
https://hg.mozilla.org/comm-central/rev/a38e5c83cbfa

Note You need to log in before you can comment on or make changes to this bug.