Memory consumption growth since June 16 on Nightly/Win 6.1 x64

RESOLVED DUPLICATE of bug 767348

Status

RESOLVED DUPLICATE of bug 767348
7 years ago
7 years ago

People

(Reporter: mihaelav, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

On June 14 and 15 there were 2 memory spikes and the since June 16 the memory consumption is showing an ascending trend, with spikes, on Win 7 64bit .
The explicit memory shows a boost of ~25MB (from aprox 125MB to aprox 150MB).
For the max resident memory, the growth is of ~30 MB (from aprox 160MB to aprox 190MB).
Also, the duration increased for ~380s to 400s, with a spike of 440son July 15.

Charts:
http://mozmill-ci.blargon7.com/#/endurance/charts?branch=16.0&platform=Windows%20NT&from=2012-06-04&to=2012-07-02

The tests which show most important growths are:
* /testTabView_OpenNewTab/test1.js->testOpenNewTab
        average resident  average explicit  max resident  max explicit
13 Jun:      119                79               136          98 
14 Jun:      145               107               175          139
16 Jun:      125                84               149          110
19 Jun:      133                92               157          118   

* /testTabbedBrowsing_OpenNewTab/test1.js->testOpenNewTab
        average resident  average explicit  max resident  max explicit
13 Jun:      141                99               166          128
14 Jun:      148               108               195          161
16 Jun:      140                98               169          133
19 Jun:      149               108               192          154   

Note that there are no reports between June 16 and 19.

Reports:
- http://mozmill-ci.blargon7.com/#/endurance/report/e67171ea696231bb192f56561505d77f (June 13)
- http://mozmill-ci.blargon7.com/#/endurance/report/e67171ea696231bb192f5656151043ff (June 14)
- http://mozmill-ci.blargon7.com/#/endurance/report/8bf3fa70d3d9a46d3e7617383b0d622f (June 16)
- http://mozmill-ci.blargon7.com/#/endurance/report/c67fb1fc2ea8384105b843e32c043114 (June 19)

Win 7x64 overall memory increase (between June 13 and 14):
Explicit memory (MB): Maximum: 128 / Average: 75 -> Maximum: 161 / Average: 83
Resident memory (MB): Maximum: 166 / Average: 114 -> Maximum: 195 / Average: 121

Pushlog (June 13-14): 
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=964b11fea7f1&tochange=880f30ecdf6b

Pushlog (June 16-19): 
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=4e3362864fbd&tochange=373e6f9264e6
(Reporter)

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 767348
You need to log in before you can comment on or make changes to this bug.