Call to isLaunchable in getSelf/getInstalled/getAll/getNotInstalled needs to be the app origin, not the install origin

VERIFIED FIXED in Firefox 16

Status

Firefox Graveyard
Web Apps
VERIFIED FIXED
5 years ago
a year ago

People

(Reporter: jsmith, Assigned: Felipe)

Tracking

unspecified
Firefox 16

Details

(Whiteboard: [qa!])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Steps:

1. Go to marketplace.mozilla.org
2. Install a free web application
3. Uninstall the free web application
4. Go to app page for the app in step #2

Expected:

The app install button should be showed as "install"

Actual:

The app install button is still showed as "installed." Under the hood, they are using getInstalled() to determine this.
(Reporter)

Updated

5 years ago
See Also: → bug 768276
(Reporter)

Comment 1

5 years ago
Looks like this generally applies to getAll() and getInstalled()
Summary: Uninstalling an app on Windows - Marketplace still shows that the app is "installed" even though getInstalled is used → Uninstalling an app on Windows - App still considered installed by getInstalled() from Marketplace and getAll() from myapps
(Reporter)

Updated

5 years ago
OS: Windows 7 → All
Hardware: x86_64 → All
Summary: Uninstalling an app on Windows - App still considered installed by getInstalled() from Marketplace and getAll() from myapps → Call to isLaunchable in getSelf/getInstalled/getAll/getNotInstalled needs to be the app origin, not the install origin
(Assignee)

Comment 2

5 years ago
Pushed patch to try, https://tbpl.mozilla.org/?tree=Try&rev=b7eafe9208af
Builds to appear at: http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/felipc@gmail.com-b7eafe9208af
Assignee: nobody → felipc
Status: NEW → ASSIGNED
(Reporter)

Comment 3

5 years ago
Working with Felipe, we've figured out the root cause. Looks like the calls to isLaunchable in getSelf/getInstalled/getAll/getNotInstalled is using the install origin, not the app origin. That explains why there's a lot of problems being seen.
(Reporter)

Updated

5 years ago
Duplicate of this bug: 770307
(Reporter)

Updated

5 years ago
Duplicate of this bug: 770380
(Assignee)

Comment 6

5 years ago
Created attachment 638545 [details] [diff] [review]
Patch

Huh I was using the wrong origin to check if an app was installed, which had the amusing effect of considering if an app was installed or not based on if you had the Marketplace app itself installed
Attachment #638545 - Flags: review?(fabrice)
(Reporter)

Updated

5 years ago
Duplicate of this bug: 770311
Attachment #638545 - Flags: review?(fabrice) → review+
(Assignee)

Comment 8

5 years ago
http://hg.mozilla.org/mozilla-central/rev/8155cc5972d6
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 16
(Reporter)

Updated

5 years ago
Whiteboard: [qa+]
(Reporter)

Comment 9

5 years ago
Did a good amount of testing with the try build on Windows - it works! Did tests such as:

- Installing and uninstalling apps on marketplace
- Viewing apps on the myapps dashboard
- Installing apps with and without appcache support
- Testing apps natively vs. acquired
Just tested with Linux and it's working.
(Reporter)

Updated

5 years ago
QA Contact: jsmith
(Reporter)

Comment 11

5 years ago
Verified on Nightly for Windows 7, Windows XP, OS X 10.7, and Ubuntu 12.
Status: RESOLVED → VERIFIED
Whiteboard: [qa+] → [qa!]
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.