aol.com - Connection times out in Mozilla, works fine in other browsers

VERIFIED FIXED

Status

Tech Evangelism Graveyard
English US
P1
normal
VERIFIED FIXED
17 years ago
3 years ago

People

(Reporter: Sean Harding, Assigned: bc)

Tracking

Details

(URL)

(Reporter)

Description

17 years ago
On http://www.aol.com/aim/mobile/sms/setup_select_carrier.htm, there is a form
that makes a POST to http://otap.oscar.aol.com/?Cmd=SignOn&carrier=voicestream.
In Mozilla, clicking the button results in several seconds of waiting (with
"Resolving host otap.oscar.aol.com" in the status bar), and then the message
"The operation timed out when attempting to contact otap.oscar.aol.com."

However, at the same time, this URL works fine from Netscape 4.78 running on the
same machine, and telnets to port 80 of otap.oscar.aol.com work fine (including
manually typing in the HTTP POST and getting back the right info).

This is happened more than ten times in a row, so it doesn't seem to be a
one-time event.
otap.oscar.aol.com has CNAME mob-m01.blue.aol.com (IP 64.12.160.227).
In NS 4.76 http://otap.oscar.aol.com/?Cmd=SignOn&carrier=voicestream works for
me, but not http://mob-m01.blue.aol.com/?Cmd=SignOn&carrier=voicestream or
http://64.12.160.227/?Cmd=SignOn&carrier=voicestream . Maybe they answer only
when receiving "Host: otap.oscar.aol.com". Do we send a wrong Host-Header?

Confirming, 2001-04-20-21, Win NT.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
That was wrong. A GET to http://otap.oscar.aol.com/?Cmd=SignOn&carrier=voicestream
fails in NS 4.76 too.
Finally found the real problem: otap.oscar.aol.com is not able to handle
User-Agent strings with a length greater than 63 chars. Fails without giving an
error.

-> Evangelism.
Component: Networking: HTTP → Evangelism
(Reporter)

Comment 4

17 years ago
Oh boy. That's a good one. I never would have caught that. Thanks!

Comment 5

17 years ago
Changing owner to evangelism
Assignee: neeti → blakeross

Comment 6

17 years ago
Reassigning evangelism bugs to new owner (bclary@netscape.com).
Assignee: blakeross → bclary
Priority: -- → P1
Summary: Connection times out in Mozilla, works fine in other browsers → aol.com - Connection times out in Mozilla, works fine in other browsers
looking for a contact...
They have been contacted and are looking into the situation. Any helpful
comments on how they can diagnose the problem with their server would be
appreciated.
Status: NEW → ASSIGNED
From the administrator of the otap.oscar.aol.com server:
<quote>
The limitation of the user-agent field is presently 128 characters,
which I will widen to 256 for the next maintenance release.

However, the Netscape 6.1 user-agent field (88 chars) still does not
exceed the 128 char limit.

I've downloaded the NS 6.1 client, and it seems to work fine for me. 

Do you have any other information that I can use to localize this
problem?  

</quote>

Can anyone who has seen this problem please reply so that we can determine what
the problem is and if it still exists?
This seems to be fixed. The limit for the user-agent string is now 126 chars,
which should be enough for Mozilla. I cannot see any further problem, but I have
no AIM login to test.

BTW, if a server cannot handle a request because of internal limitations, it
should not time out, but send a 500 (Internal Server Error) error message.

Comment 11

17 years ago
This does now seem to work. I can login using my AIM ID.
Marking FIXED.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
All Evangelism Bugs are now in the Product Tech Evangelism. See bug 86997 for
details.
Component: Evangelism → US English
Product: Browser → Tech Evangelism
Version: other → unspecified

Comment 14

17 years ago
Verified
2002022703/WinXP
Status: RESOLVED → VERIFIED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.