gitolite: https? urls would be nicer if more restful

VERIFIED FIXED

Status

VERIFIED FIXED
6 years ago
4 years ago

People

(Reporter: hwine, Unassigned)

Tracking

Details

(Reporter)

Description

6 years ago
Current working http urls are of the form:
  http://git1.dmz.scl3.mozilla.com/?p=integration/mozilla-inbound.git;a=summary
(query string formatting)

For numerous reasons, it would be nicer if a RESTful URL scheme were used, as is used with hg.m.o, github.com, bitbucket.org, etc.

This appears to be supported by gitolite, as something very close to that is listed as a URL on the page above:
 'http://git1.dmz.scl3.mozilla.com/git/'/integration/mozilla-inbound.git

Comment 1

6 years ago
I've fixed this, not for http browsing but for http and ssh checkout.  The functionality was correct but strings listed at the top of the pages were incorrect.  To allow this sort of functionality to view pages would require quite a bit of ScriptAlias matching in httpd and would need to be revised every time a repository is added.

This is not really workable without spending a lot of time writing httpd scripts to allow this.  Are the cosmetic improvements actually worth that time?

[root@boris ~]# git clone http://git1.dmz.scl3.mozilla.com/integration/mozilla-inbound.git
Cloning into 'mozilla-inbound'...
remote: Counting objects: 42029 
<yadda yadda>
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Updated

6 years ago
Duplicate of this bug: 770320
(Reporter)

Comment 3

6 years ago
Looks good - the key thing was to have the URL we display be one that actually worked for cloning via copy/paste for end user. 

That works and web browsing works. Ship it! ;)
Status: RESOLVED → VERIFIED
Component: Server Operations: Developer Services → General
Product: mozilla.org → Developer Services
You need to log in before you can comment on or make changes to this bug.