Closed Bug 770364 Opened 10 years ago Closed 10 years ago

crash in nsPresContext::GetRootPresContext

Categories

(Core :: Layout, defect)

16 Branch
All
macOS
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: automatedtester, Unassigned)

References

()

Details

(Keywords: crash, regression)

Crash Data

This bug was filed from the Socorro interface and is 
report bp-f6165676-1fba-4aa8-a10b-5d6d42120702 .
============================================================= 


STR:

1. Go to https://github.com/mozilla-b2g/gaia/tree/6caf9e068886be4b678f42c2592919c7c14a04fe
2. go down a few levels in the test directory
3. press backspace to go back and it crashes

This could be related to bug 770041
I can't reproduce this, does it crash consistently for you?

Please try again in Safe Mode, I think it might be addon related.
Component: Keyboard Navigation → Layout
Product: Firefox → Core
QA Contact: keyboard.navigation → layout
Version: 14 Branch → 16 Branch
I just hit this:

bp-e0f34493-ce3a-45e0-8197-5b4fe2120703
bp-181059b1-fa1b-4354-9b11-fb87a2120703

The first was from a long browser session, I had been reading http://en.wikipedia.org/wiki/A_Fire_Upon_the_Deep#Zones_of_Thought, clicked the author's name (http://en.wikipedia.org/wiki/Vernor_Vinge), and then relatively quickly clicked back (As I noticed a mention of Usenet on the first page, but the latter page started loading before I could read it).

The second (corrupt) bp report happened seconds after the browser session restored, and I did exactly the same thing.
And again, same steps: bp-0a11728a-9e04-462b-b58b-74ae32120703

Can't seem to reproduce with a clean profile, though. Perhaps depends on something else? I've only got a few common addon, or maybe one of the 6 apptabs that are also session-restoring on startup...
Below is my about:support. With a clean profile I am getting details as in bug 770041 so perhaps its addon related. 

Like :Dolske I get my first crash and then I get an empty stack in the next crash

See 
https://crash-stats.mozilla.com/report/index/bp-f489f9d0-142a-40f7-bbbc-9b96c2120702
https://crash-stats.mozilla.com/report/index/bp-408f831e-4cd3-4b9a-8f6f-127db2120702

  Application Basics

        Name
        Firefox

        Version
        16.0a1

        User Agent
        Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:16.0) Gecko/16.0 Firefox/16.0

        Profile Folder

          Show in Finder

        Enabled Plugins

          about:plugins

        Build Configuration

          about:buildconfig

        Crash Reports

          about:crashes

        Memory Use

          about:memory

  Extensions

        Name

        Version

        Enabled

        ID

        DOM Inspector
        2.0.12
        true
        inspector@mozilla.org

        Firebug
        1.9.2
        true
        firebug@software.joehewitt.com

        Firefinder for Firebug
        1.2.2
        true
        firefinder@robertnyman.com

        Github tweaks for Bugzilla
        1.7
        true
        jid0-AWShpy08txla2QGDYvv5bed4sjs@jetpack

        Github+Travis
        0.2.2
        true
        githubtravis@theautomatedtester.co.uk

        Inspect Context
        1.00
        true
        inspectcontext@max.max

        MemChaser
        0.3
        true
        memchaser@quality.mozilla.org

        Selenium IDE
        1.8.1
        true
        {a6fd85ed-e919-4a43-a5af-8da18bda539f}

        Selenium IDE: C# Formatters
        1.8.1
        true
        csharpformatters@seleniumhq.org

        Selenium IDE: Java Formatters
        1.8.1
        true
        javaformatters@seleniumhq.org

        Selenium IDE: Python Formatters
        1.8.1
        true
        pythonformatters@seleniumhq.org

        Selenium IDE: Ruby Formatters
        1.8.1
        true
        rubyformatters@seleniumhq.org

        Test Pilot
        1.2.1
        true
        testpilot@labs.mozilla.com

        Wiktionary and Google Translate
        5.9.1
        true
        googledictionary@toptip.ca

        YSlow
        3.1.0
        true
        yslow@yahoo-inc.com

        DivX Plus Web Player HTML5 <video>
        2.1.2.145
        false
        {23fcfd51-4958-4f00-80a3-ae97e717ed8b}

        Selenium IDE: Groovy Formatters
        1.0.0
        false
        groovyformatters@seleniumhq.org

        Selenium IDE: Perl Formatter
        1.0.0
        false
        perlformatters@seleniumhq.org

        Selenium IDE: PHP Formatters
        1.0.0
        false
        phpformatters@seleniumhq.org

  Important Modified Preferences

      Name

      Value

        accessibility.typeaheadfind.autostart
        false

        accessibility.typeaheadfind.flashBar
        0

        browser.cache.disk.capacity
        1048576

        browser.cache.disk.enable
        false

        browser.cache.disk.smart_size.first_run
        false

        browser.cache.disk.smart_size_cached_value
        1048576

        browser.cache.memory.enable
        false

        browser.link.open_newwindow.restriction
        0

        browser.places.smartBookmarksVersion
        4

        browser.startup.homepage_override.buildID
        20120702030551

        browser.startup.homepage_override.mstone
        16.0a1

        dom.popup_allowed_events
        change click dblclick mouseup reset submit keypress

        extensions.lastAppVersion
        16.0a1

        javascript.options.mem.log
        true

        network.cookie.prefsMigrated
        true

        places.database.lastMaintenance
        1340979195

        places.history.expiration.transient_current_max_pages
        104858

        places.history.expiration.transient_optimal_database_size
        167772160

        print.macosx.pagesetup-2
        PD94bWwgdmVyc2lvbj0iMS4wIiBlbmNvZGluZz0iVVRGLTgiPz4KPCFET0NUWVBFIHBsaXN0IFBVQkxJQyAiLS8vQXBwbGUvL0RURCBQTElTVCAxLjAvL0VO…

        print.print_bgcolor
        false

        print.print_bgimages
        false

        print.print_command

        print.print_downloadfonts
        false

        print.print_evenpages
        true

        print.print_in_color
        true

        print.print_margin_bottom
        0.5

        print.print_margin_left
        0.5

        print.print_margin_right
        0.5

        print.print_margin_top
        0.5

        print.print_oddpages
        true

        print.print_orientation
        0

        print.print_page_delay
        50

        print.print_paper_data
        0

        print.print_paper_height
        11.00

        print.print_paper_size_type
        1

        print.print_paper_size_unit
        0

        print.print_paper_width
        8.50

        print.print_printer

        print.print_reversed
        false

        print.print_scaling
        1.00

        print.print_shrink_to_fit
        true

        print.print_to_file
        false

        print.print_unwriteable_margin_bottom
        57

        print.print_unwriteable_margin_left
        25

        print.print_unwriteable_margin_right
        25

        print.print_unwriteable_margin_top
        25

        privacy.donottrackheader.enabled
        true

        privacy.sanitize.migrateFx3Prefs
        true

        security.disable_button.openCertManager
        false

        security.warn_viewing_mixed
        false

  Graphics

        Vendor ID
        0x10de

        Device ID
        0x a29

        WebGL Renderer
        NVIDIA Corporation -- NVIDIA GeForce GT 330M OpenGL Engine -- 2.1 NVIDIA-7.18.18

        GPU Accelerated Windows
        1/1 OpenGL

        AzureBackend
        quartz

  JavaScript

        Incremental GC
        1

  Accessibility

        Activated
        0

  Library Versions

        Expected minimum version

        Version in use

        NSPR
        4.9.2 Beta
        4.9.2 Beta

        NSS
        3.13.5.0 Basic ECC
        3.13.5.0 Basic ECC

        NSS Util
        3.13.5.0
        3.13.5.0

        NSS SSL
        3.13.5.0 Basic ECC
        3.13.5.0 Basic ECC

        NSS S/MIME
        3.13.5.0 Basic ECC
        3.13.5.0 Basic ECC
I *think* this will be fixed by the patch in bug 770041, since it reverts the behaviour of GetParentPresContext/GetRootPresContext.

This should be in tonight's nightly, it was just merged to m-c.
I can't reproduce this now so am closing. If I get it again I will reopen
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → WORKSFORME
Blocks: dlbi
Keywords: regression
You need to log in before you can comment on or make changes to this bug.