Unlocalizable strings on the page "Statistics"

VERIFIED FIXED

Status

Marketplace
Statistics
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: JasnaPaka, Assigned: clouserw)

Tracking

Points:
---

Details

Attachments

(3 attachments)

(Reporter)

Description

6 years ago
https://marketplace-dev.allizom.org/dbg/app/favimon-beta/statistics/?last=30
* "custom range"

https://marketplace-dev.allizom.org/dbg/app/favimon-beta/statistics/sales/?last=30
* links "Amount Earned",  "Units Sold" and "Units Refunded"
* "Metric Type", "Currency" and "Source"
* "Amount Earned by Date"
* "Amount Earned"
* graph has english strings

With graph there is a problem on all subpages. It looks like we cannot localize strings which are in.
(In reply to Pavel Cvrcek (Mozilla.cz) [:JasnaPaka] from comment #0)
> https://marketplace-dev.allizom.org/dbg/app/favimon-beta/statistics/?last=30
> * "custom range"

It's there: https://github.com/mozilla/zamboni/blob/master/mkt/stats/templates/appstats/stats.html#L115 Locales haven't been updated to reflect this though.

> https://marketplace-dev.allizom.org/dbg/app/favimon-beta/statistics/sales/
> ?last=30
> * links "Amount Earned",  "Units Sold" and "Units Refunded"
> * "Metric Type", "Currency" and "Source"
> * "Amount Earned by Date"
> * "Amount Earned"
> * graph has english strings

I'm not sure I understand the problem. These strings have also recently changed, but are you saying that none of these above are localized?

/Users/chris/Sites/projects/zamboni3/media/js/mkt/stats/chart.js:
  278              switch (metricTypes[metric]) {
  279                  case "currency": case "revenue":
  280:                     baseConfig.yAxis.title.text = gettext('Amount Earned');
  281                      yFormatter = currencyFormatter;
  282                      break;

/Users/chris/Sites/projects/zamboni3/media/js/mkt/stats/csv_keys.js:
    7      },
    8      revenue: {
    9:         'count': gettext('Amount Earned')
   10      },
   11      sales: {
   ..
   16      },
   17      currency_revenue: {
   18:         'count': gettext('Amount Earned')
   19      },
   20      currency_sales: {
   ..
   25      },
   26      source_revenue: {
   27:         'count': gettext('Amount Earned')
   28      },
   29      source_sales: {
   ..
  126          ],
  127          'revenue' : [
  128:             gettext('Amount Earned, last {0} days'),
  129:             gettext('Amount Earned {0} to {1}')
  130          ],
  131          'refunds' : [
  ...
  138          ],
  139          'currency_revenue' : [
  140:             gettext('Total Amount Earned by Currency'),
  141:             gettext('Total Amount Earned by Currency')
  142          ],
  143          'currency_refunds' : [
  ...
  150          ],
  151          'source_revenue' : [
  152:             gettext('Total Amount Earned by Source'),
  153:             gettext('Total Amount Earned by Source')
  154          ],
  155          'source_refunds' : [

/Users/chris/Sites/projects/zamboni3/mkt/stats/templates/appstats/reports/currency.html:
    4    <div class="criteria sales-filters island">
    5      {% set links = [
    6:       (addon.get_stats_url(action='currency_revenue', inapp=inapp), _('Amount Earned')),
    7        (addon.get_stats_url(action='currency_sales', inapp=inapp), _('Units Sold')),
    8        (addon.get_stats_url(action='currency_refunds', inapp=inapp), _('Units Refunded'))

/Users/chris/Sites/projects/zamboni3/mkt/stats/templates/appstats/reports/currency_revenue.html:
    1  {% extends 'appstats/reports/currency.html' %}
    2  
    3: {% set title = _('Amount Earned by Currency') %}
    4  

/Users/chris/Sites/projects/zamboni3/mkt/stats/templates/appstats/reports/finance.html:
    8    <div class="criteria sales-filters island">
    9      {% set links = [
   10:       (addon.get_stats_url(action='revenue', inapp=inapp), _('Amount Earned')),
   11        (addon.get_stats_url(action='sales', inapp=inapp), _('Units Sold')),
   12        (addon.get_stats_url(action='refunds', inapp=inapp), _('Units Refunded'))

/Users/chris/Sites/projects/zamboni3/mkt/stats/templates/appstats/reports/revenue.html:
    1  {% extends 'appstats/reports/finance.html' %}
    2  
    3: {% set title = _('Amount Earned by Date') %}
    4  

/Users/chris/Sites/projects/zamboni3/mkt/stats/templates/appstats/reports/source.html:
    4    <div class="criteria sales-filters island">
    5      {% set links = [
    6:       (addon.get_stats_url(action='source_revenue', inapp=inapp), _('Amount Earned')),
    7        (addon.get_stats_url(action='source_sales', inapp=inapp), _('Units Sold')),
    8        (addon.get_stats_url(action='source_refunds', inapp=inapp), _('Units Refunded'))

> With graph there is a problem on all subpages. It looks like we cannot
> localize strings which are in.

Like which parts? The numerals?
Component: General → Statistics
QA Contact: general → statistics
(Reporter)

Comment 2

6 years ago
Created attachment 638876 [details]
Screenshot

(In reply to Chris Van Wiemeersch [:cvan] from comment #1)
> > https://marketplace-dev.allizom.org/dbg/app/favimon-beta/statistics/sales/
> > ?last=30
> > * links "Amount Earned",  "Units Sold" and "Units Refunded"
> > * "Metric Type", "Currency" and "Source"
> > * "Amount Earned by Date"
> > * "Amount Earned"
> > * graph has english strings
> 
> I'm not sure I understand the problem. These strings have also recently
> changed, but are you saying that none of these above are localized?

See screenshot. All these strings are not localizable at this moment. I'm talking about current situation which I can see on the stage server and what I see in .po file.
(Assignee)

Comment 3

6 years ago
This bug (and the others like it) are usually caused by my not extracting l10n yet.  I pulled new strings, these are in the .po now. Thanks.
Assignee: nobody → clouserw
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Comment 4

6 years ago
Not all the strings are localized. Please see attached screenshot. If these strings should not be localized, please close the bug again.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 5

6 years ago
Created attachment 650029 [details]
Some strings are still not localized.
(Assignee)

Comment 6

6 years ago
Everything is localized now.  Eg. https://marketplace-dev.allizom.org/app/evernote-web/statistics/?last=30
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED

Comment 7

6 years ago
Please let me know if the sections from the last attachment should be localized. 
If not, please close the bug again.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 8

6 years ago
Created attachment 678763 [details]
Some sections still not localized
(Assignee)

Comment 9

6 years ago
The debug language uses en-US dates so I think all of those are fine.
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED

Comment 10

6 years ago
Then I will mark it as verified based on the same screenshot.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.