Broken shortcut keys for next and previous page

RESOLVED FIXED

Status

RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: order-t, Assigned: u60234)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Created attachment 638627 [details]
History.png

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:13.0) Gecko/20100101 Firefox/13.0.1
Build ID: 20120614114901

Steps to reproduce:

Type cmd+Ö or cmd+Ä where there is a next or previous page.


Actual results:

Nothing. The history menu just flashes for a second.


Expected results:

Firefox should have switched to next or previous page.

 I know there are other shortcut keys; backspace, shift + backspace, cmd + >, cmd + <.
However, Cmd + Ö and Cmd + Ä were the most efficient. They worked when the cursor was in a text box or on flash sites.

I attach a screen shot from the history menu.
Does running in safe mode, or creating a new profile for firefox would solve this probem?

Creating a new profile: http://kb.mozillazine.org/Profile_Manager#Mac_OS_X

If not, this add-on might allow you to fix the shortcuts:

https://addons.mozilla.org/en-US/firefox/addon/customizable-shortcuts/reviews/
Editing for typos and wrong link for the add-on (sorry).

> Does running in safe mode, or creating a new profile for firefox solve this probem?
> 
> Creating a new profile: http://kb.mozillazine.org/Profile_Manager#Mac_OS_X
> 
> If not, this add-on might allow you to fix the shortcuts:
> 
> https://addons.mozilla.org/en-US/firefox/addon/customizable-shortcuts/
(Reporter)

Comment 3

7 years ago
Safe mode or creating a new profile had no effect. But the add-on worked, both when the cursor was in text boxes and on flash sites. Even when I used the same shortcuts, like Cmd > and Cmd <, in the add-on, it improved them and made them work in text boxes and flash sites
Were these keyboard shortcuts working in a previous Firefox release without any add-ons installed?
(Reporter)

Comment 5

7 years ago
(In reply to Anthony Hughes, Mozilla QA (irc: ashughes) from comment #4)
> Were these keyboard shortcuts working in a previous Firefox release without
> any add-ons installed?

Yes, they worked from 4.0, when I started to use Firefox, and were broken in 13.0
I know it's tedious, but can you please start working your way back through the releases, starting with Firefox 12, to find out when this started happening for you? You'll find them on ftp.mozilla.org/pub/firefox/releases.

Thank you
(Reporter)

Comment 7

7 years ago
(In reply to Anthony Hughes, Mozilla QA (irc: ashughes) from comment #6)
> I know it's tedious, but can you please start working your way back through
> the releases, starting with Firefox 12, to find out when this started
> happening for you? You'll find them on ftp.mozilla.org/pub/firefox/releases.
> 
> Thank you

I'm not sure I follow you. I've used every version of Firefox from 4.01 to current 13.01. The shortcut keys ceased to work in version 13.0.

I tested version 12.0 earlier today and the keyboard shortcuts worked.
That seems to indicate this is a regression within the Firefox 13 timeframe. Can you please use the mozregression tool to narrow down the regression range? The initial dates to use would be 2012-02-01 and 2012-03-13. Alternatively you can download the nightlies in the range manually, but it will be much more tedious without mozregression.

http://harthur.github.com/mozregression/
Keywords: regressionwindow-wanted
(Reporter)

Comment 9

7 years ago
(In reply to Anthony Hughes, Mozilla QA (irc: ashughes) from comment #8)
> That seems to indicate this is a regression within the Firefox 13 timeframe.
> Can you please use the mozregression tool to narrow down the regression
> range? The initial dates to use would be 2012-02-01 and 2012-03-13.
> Alternatively you can download the nightlies in the range manually, but it
> will be much more tedious without mozregression.
> 
> http://harthur.github.com/mozregression/

It was english versions that were downloaded with the mozregression tool. The back keyboard shortcut was Cmd [ and the forward key was Cmd ]. None of them worked. It was the same as in my swedish version. The history menu just flashed.

I paste the command line result:

Fredrik-Toftereds-MacBook:~ Fredrik$ mozregression --good=2012-02-01 --bad=2012-03-13

Downloading nightly from 2012-02-21

Starting nightly

Was this nightly good, bad, or broken? (type 'good', 'bad', 'skip', 'retry', or 'exit' and press Enter): bad

Downloading nightly from 2012-02-11

Starting nightly

Was this nightly good, bad, or broken? (type 'good', 'bad', 'skip', 'retry', or 'exit' and press Enter): bad

Downloading nightly from 2012-02-06

Starting nightly

Was this nightly good, bad, or broken? (type 'good', 'bad', 'skip', 'retry', or 'exit' and press Enter): bad

Downloading nightly from 2012-02-03

Starting nightly

Was this nightly good, bad, or broken? (type 'good', 'bad', 'skip', 'retry', or 'exit' and press Enter): bad

Downloading nightly from 2012-02-02

Starting nightly

Was this nightly good, bad, or broken? (type 'good', 'bad', 'skip', 'retry', or 'exit' and press Enter): *** nsHTMLElement::FinishDecoderSetup() mDecoder=0x11a432600 stream=0x123b54000 src=http://videos-cdn.mozilla.net/serv/qa/qa-360p-mp4.theora.ogv
bad


Last good nightly: 2012-02-01
First bad nightly: 2012-02-02

Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?startdate=2012-02-01&enddate=2012-02-02
So it looks like all the Nightlies are broken for you then? Including the very first Firefox 13.0 Nightly? Can you go to ftp://ftp.mozilla.org/pub/firefox/nightly/2012/02/2012-02-01-03-11-46-mozilla-central/ and download the build to test this manually, just to confirm. Note that all of our Nightlies are only build with the en-US locale. Are you running a particular locale when reproducing this issue?
(Reporter)

Comment 11

7 years ago
(In reply to Anthony Hughes, Mozilla QA (irc: ashughes) from comment #10)
> So it looks like all the Nightlies are broken for you then? Including the
> very first Firefox 13.0 Nightly? Can you go to
> ftp://ftp.mozilla.org/pub/firefox/nightly/2012/02/2012-02-01-03-11-46-
> mozilla-central/ and download the build to test this manually, just to
> confirm. Note that all of our Nightlies are only build with the en-US
> locale. Are you running a particular locale when reproducing this issue?

I'm running a swedish version:
Back: sv-SE Cmd Ö
en-US Cmd [

Forward: sv-SE Cmd Ä  
en-US Cmd ]

In the en-US versions, not even firefox-12.0a1.en-US.mac worked.
So..

Firefox sv-SE, CMD+Ö and CMD+Ä does not work.
Firefox en-US, CMD+[ and CMD+] does not work.

...and...
Firefox 12.0a1 reproduces the bug.
Firefox 12.0-release does not.
Firefox 13.0-release reproduces the bug.

Is this correct? Sorry, I'm having a hard time following which versions of Firefox and locales this bug reproduces for you specifically with CMD+Ö and CMD+Ä. How can I test this myself, considering I have an en_US keyboard.
(Reporter)

Comment 13

7 years ago
(In reply to Anthony Hughes, Mozilla QA (irc: ashughes) from comment #12)
> So..
> 
> Firefox sv-SE, CMD+Ö and CMD+Ä does not work.
> Firefox en-US, CMD+[ and CMD+] does not work.
> 
> ...and...
> Firefox 12.0a1 reproduces the bug.
> Firefox 12.0-release does not.
> Firefox 13.0-release reproduces the bug.
> 
> Is this correct? Sorry, I'm having a hard time following which versions of
> Firefox and locales this bug reproduces for you specifically with CMD+Ö and
> CMD+Ä. How can I test this myself, considering I have an en_US keyboard.

I tested the sv-SE and en-US releases of Firefox 12.0. The shortcut keys worked in sv-SE but not in en-US.

Is there a sv-SE version of 13.0a1? I suspect it started there.
(In reply to order from comment #13)
> I tested the sv-SE and en-US releases of Firefox 12.0. The shortcut keys
> worked in sv-SE but not in en-US.

I believe this might be expected. CMD+Ö is not a known key to en-US keyboard layouts as far as I know. So as long as this continues to work with sv-SE, or with en-US and the add-on mentioned earlier, I don't think this is a bug. 

> Is there a sv-SE version of 13.0a1? I suspect it started there.

Not that I know of, we only build en-US versions of Nighty
(Reporter)

Comment 15

7 years ago
(In reply to Anthony Hughes, Mozilla QA (irc: ashughes) from comment #14)
> (In reply to order from comment #13)
> > I tested the sv-SE and en-US releases of Firefox 12.0. The shortcut keys
> > worked in sv-SE but not in en-US.
> 
> I believe this might be expected. CMD+Ö is not a known key to en-US keyboard
> layouts as far as I know. So as long as this continues to work with sv-SE,
> or with en-US and the add-on mentioned earlier, I don't think this is a bug. 

Maybe I expressed myself badly. What I meant was this: In the 12.0 release, CMD+Ö and CMD+Ä worked in sv-SE but CMD+[ and CMD+] did not work in en-US. Of course, one couldn't expect that CMD+Ö would work in the en-US version. From version 13.0 CMD+Ö and CMD+Ä have ceased to work with sv-SE.

The history menu says that CMD+Ö takes you back and CMD+Ä takes you forward. Until version 13.0 they also did. From version 13.0 they do not. How can that not be a bug? If the function can't be brought back, the history menu should stop telling that one can navigate with CMD+Ö and CMD+Ä.

> > Is there a sv-SE version of 13.0a1? I suspect it started there.
> 
> Not that I know of, we only build en-US versions of Nighty
If the history menu tells you CMD+Ö / CMD+Ä are valid shortcuts then yes, this should still be working. It's possibly a problem with the locale's dtd. Moving it so it can be investigated further.
Component: Untriaged → Localization
Product: Firefox → Core
Keyboard shortcut problems seem to be a common thing lately. Moving this to the Swedish locale so they can take a look, and CCing Henrik so he can check for conflicts.
Assignee: nobody → hasse
Component: Localization → sv-SE / Swedish
Product: Core → Mozilla Localizations
QA Contact: slicedlime
Version: 13 Branch → unspecified
See also bug 306585 comment 61. At least the German locale is also affected. Not really sure if this is really a wider issue across locales. CC'ing Masayuki.
Keywords: regression
IIRC, I didn't touch keyboard event handling on Cocoa at Fx13...
(In reply to Anthony Hughes, Mozilla QA (irc: ashughes) from comment #14)
> > Is there a sv-SE version of 13.0a1? I suspect it started there.
> 
> Not that I know of, we only build en-US versions of Nighty

Why do you think that? We test even l10n builds with Mozmill. The downside is that we do not keep them. So those will not be helpful.

Reporter, which keyboard layout are you using? I assume the Swedish one. Can you please switch to en-Us and try such a build again? If it works what about the latest 14.0.1 release of Firefox in sv-SE?
(Assignee)

Comment 21

7 years ago
Don't know if it's related, but a key handling bug that landed for Fx13 was bug 418091.
(Reporter)

Comment 22

7 years ago
(In reply to Henrik Skupin (:whimboo) from comment #20)
> (In reply to Anthony Hughes, Mozilla QA (irc: ashughes) from comment #14)
> > > Is there a sv-SE version of 13.0a1? I suspect it started there.
> > 
> > Not that I know of, we only build en-US versions of Nighty
> 
> Why do you think that? We test even l10n builds with Mozmill. The downside
> is that we do not keep them. So those will not be helpful.
> 
> Reporter, which keyboard layout are you using? I assume the Swedish one. Can
> you please switch to en-Us and try such a build again? If it works what
> about the latest 14.0.1 release of Firefox in sv-SE?

I use Swedish keyboard layout. When I switched to en-US keyboard layout, CMD+] and Cmd+[ worked in the en-US versions of Firefox. I tested with the latest 14.01 and with nightlies from 2012-02-21-- 2012-03-12. All worked.

With swedish keyboard layout, CMD+Ö and CMD+Ä are still broken in the latest Swedish version 14.01.
(In reply to Hasse from comment #21)
> Don't know if it's related, but a key handling bug that landed for Fx13 was
> bug 418091.

Could be. Lets cc Steven for his input on it.
(Assignee)

Comment 24

7 years ago
(In reply to order from comment #22)
> With swedish keyboard layout, CMD+Ö and CMD+Ä are still broken in the latest
> Swedish version 14.01.

Can you please try today's sv-SE build from http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla-central-l10n/ and see if that works?

I can reproduce this on Linux as well, so it's probably not bug 418091. The first trunk nightly that is broken is from 2012-03-12, 2012-03-11 is OK. http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=6737b6762eb8&tochange=5ec9524de1af

It looks like we now treat non-ASCII command keys case-sensitive. If I use lower-case ö and ä in the dtd file, the back and forward commands works again on Linux. The only thing that sticks out in the regression range is bug 492931, but should that really affect chrome?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regressionwindow-wanted
OS: Mac OS X → All
Hardware: x86 → All
(In reply to comment #23)

Looks like Hasse has the answer -- that this bug is unrelated to the patch for bug 418091.
(Reporter)

Comment 26

7 years ago
(In reply to Hasse from comment #24)
> (In reply to order from comment #22)
> > With swedish keyboard layout, CMD+Ö and CMD+Ä are still broken in the latest
> > Swedish version 14.01.
> 
> Can you please try today's sv-SE build from
> http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla-
> central-l10n/ and see if that works?
> 
Yes, it did work.

> I can reproduce this on Linux as well, so it's probably not bug 418091. The
> first trunk nightly that is broken is from 2012-03-12, 2012-03-11 is OK.
> http://hg.mozilla.org/mozilla-central/
> pushloghtml?fromchange=6737b6762eb8&tochange=5ec9524de1af
> 
> It looks like we now treat non-ASCII command keys case-sensitive. If I use
> lower-case ö and ä in the dtd file, the back and forward commands works
> again on Linux. The only thing that sticks out in the regression range is
> bug 492931, but should that really affect chrome?
(Assignee)

Comment 27

7 years ago
OK, I will change to using lowercase letters then.

http://hg.mozilla.org/l10n-central/sv-SE/rev/74c45598db1c
http://hg.mozilla.org/releases/l10n/mozilla-aurora/sv-SE/rev/5f90fb1bfbe4
http://hg.mozilla.org/releases/l10n/mozilla-beta/sv-SE/rev/cbbe9653a4d2
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.