Gap rendered above element when margin-bottom applied to parent of floated elements

RESOLVED DUPLICATE of bug 1012634

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 1012634
5 years ago
3 years ago

People

(Reporter: Adrian, Unassigned)

Tracking

13 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 638629 [details]
Image showing rendering issue

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:13.0) Gecko/20100101 Firefox/13.0.1
Build ID: 20120614114901

Steps to reproduce:

Nested two divs and applied margin-bottom to the inner one.
Added a two divs inside the inner div with width 50% and floated left.
Added a div below the two floated left with clear:both applied to it.

Example at: http://jsfiddle.net/CdrpC/8/


Actual results:

Gap rendered above the two wrapping divs equal to that of the margin applied to the bottom of the inner one.


Expected results:

There should only be a gap (margin) at the bottom.

Comment 1

5 years ago
This is a really old bug. I can reproduce it using any build from Firefox 3.6.28 - Nightly 20120703. I haven't bothered checking older builds.

Updated

5 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

3 years ago
I can confirm this bug, which seems to be there since a long time, and never fixed !

Could someone work on it ? Thanks.
Dupping forward to a bug with a testcase attached directly.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1012634
You need to log in before you can comment on or make changes to this bug.